aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apostrophe/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/apostrophe/APKBUILD')
-rw-r--r--testing/apostrophe/APKBUILD48
1 files changed, 34 insertions, 14 deletions
diff --git a/testing/apostrophe/APKBUILD b/testing/apostrophe/APKBUILD
index 96e8f929591..88aa3438902 100644
--- a/testing/apostrophe/APKBUILD
+++ b/testing/apostrophe/APKBUILD
@@ -1,30 +1,51 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apostrophe
-pkgver=2.5
-pkgrel=1
+pkgver=2.6.3
+pkgrel=6
pkgdesc="distraction free Markdown editor for GNU/Linux made with GTK+"
-url="https://gitlab.gnome.org/somas/apostrophe"
-arch="x86_64" # py3-pypandoc
+url="https://gitlab.gnome.org/World/apostrophe"
+arch="aarch64 x86_64" # py3-pypandoc
license="GPL-3.0-or-later"
-depends="py3-regex py3-setuptools py3-levenshtein py3-enchant py3-gobject3
- py3-cairo py3-pypandoc webkit2gtk gtk+3.0 libhandy1 py3-chardet gspell"
+depends="
+ font-fira-otf
+ gspell
+ gtk+3.0
+ libhandy1
+ py3-cairo
+ py3-chardet
+ py3-enchant
+ py3-gobject3
+ py3-levenshtein
+ py3-pypandoc
+ py3-regex
+ py3-setuptools
+ webkit2gtk
+ "
makedepends="meson gtk+3.0-dev gobject-introspection-dev gspell-dev gettext-dev
libhandy1-dev sassc"
checkdepends="appstream-glib desktop-file-utils"
subpackages="$pkgname-lang"
-source="https://gitlab.gnome.org/somas/apostrophe/-/archive/v$pkgver/apostrophe-v$pkgver.tar.gz
- dont-require-py-gettext.patch
- "
+source="https://gitlab.gnome.org/World/apostrophe/-/archive/v$pkgver/apostrophe-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
+prepare() {
+ default_prepare
+ # fix font finding
+ sed -i 's|/app/share/fonts/FiraSans-Regular.ttf|/usr/share/fonts/OTF/FiraSans-Regular.otf|' \
+ data/media/css/web/base.css
+ sed -i 's|/app/share/fonts/FiraMono-Regular.ttf|/usr/share/fonts/OTF/FiraMono-Regular.otf|' \
+ data/media/css/web/base.css
+
+}
+
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -32,6 +53,5 @@ package() {
}
sha512sums="
-633df5db82af73596cd106fa26fea7c4a1dbd0f63118c467b446fa81c61e1d7d0746edb68fc6ad3758a65fd96ef3bd30b2b17bd8da4fd7e47a8294716fc746a3 apostrophe-v2.5.tar.gz
-a46505e246af5d6ebf99d8585eb5f99046a71f0c54328f0c07caef046dd0f9e403ba0be89703621f1644fd5d4be7f74fdf7308356f38afe7f21c5c57eaf08a57 dont-require-py-gettext.patch
+1820fd609efe4ac0b7babdeb2aa552a72dd9623f4caeb8eb9e638a52a546b76fda5119931d10b630234a595d227ff7090a63503fd9da94d553439b91a03ac876 apostrophe-v2.6.3.tar.gz
"