aboutsummaryrefslogtreecommitdiffstats
path: root/testing/arc-theme
diff options
context:
space:
mode:
Diffstat (limited to 'testing/arc-theme')
-rw-r--r--testing/arc-theme/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/arc-theme/APKBUILD b/testing/arc-theme/APKBUILD
new file mode 100644
index 00000000000..643345132ca
--- /dev/null
+++ b/testing/arc-theme/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=arc-theme
+pkgver=20161005
+pkgrel=0
+pkgdesc="A flat theme with transparent elements"
+url="https://github.com/horst3180/arc-theme"
+arch="noarch"
+license="GPL-3.0"
+depends="gtk-murrine-engine"
+makedepends="automake autoconf libtool gtk+3.0-dev"
+install=""
+subpackages=""
+source="arc-theme-$pkgver.tar.gz::https://github.com/horst3180/arc-theme/archive/$pkgver.tar.gz"
+builddir="$srcdir/arc-theme-$pkgver"
+
+build() {
+ cd "$builddir"
+ autoreconf -vif
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-unity \
+ --disable-cinnamon \
+ --disable-gnome-shell \
+ --disable-metacity \
+ return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="bf55ae55b07c15d044545c98ad649f2b arc-theme-20161005.tar.gz"
+sha256sums="09167228e286c3decedd2197ed6915d70d8601e7274f81cd368ac097f6c4f7e4 arc-theme-20161005.tar.gz"
+sha512sums="cbdb73424f85532d756f2b7ed781fbc49598be44e01715490c0f95a60d7e1ab1c4f58a02f1a60bc9aec7f9625a9b7190ed680888af9c6fdf8a192b935c2ebe33 arc-theme-20161005.tar.gz"