aboutsummaryrefslogtreecommitdiffstats
path: root/testing/asteroid-wallpapers/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/asteroid-wallpapers/APKBUILD')
-rw-r--r--testing/asteroid-wallpapers/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/testing/asteroid-wallpapers/APKBUILD b/testing/asteroid-wallpapers/APKBUILD
index cb19ebf6fd8..778b7603d38 100644
--- a/testing/asteroid-wallpapers/APKBUILD
+++ b/testing/asteroid-wallpapers/APKBUILD
@@ -1,22 +1,25 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=asteroid
pkgname=asteroid-wallpapers
-pkgver=0_git20200929
+pkgver=2.0.0
pkgrel=0
-_commit="a748cf9314d5798eb1bf66c3b6641eecd2d3d655"
pkgdesc="Default set of wallpapers for AsteroidOS"
url="https://github.com/AsteroidOS/asteroid-wallpapers"
arch="noarch"
license="CC0-1.0 AND CC-BY-2.0 AND CC-BY-NC-SA-2.0"
-source="https://github.com/AsteroidOS/asteroid-wallpapers/archive/$_commit/asteroid-wallpapers-$_commit.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/AsteroidOS/asteroid-wallpapers/archive/refs/tags/$pkgver.tar.gz"
options="!check" # No code to test
-builddir="$srcdir/$pkgname-$_commit"
package() {
- cd 480x480
- find . -type f | while read -r i; do
- install -Dm644 $i "$pkgdir"/usr/share/asteroid-launcher/wallpapers/$i
+ install -dm755 "$pkgdir"/usr/share/asteroid-launcher/wallpapers
+ find . -mindepth 1 -maxdepth 1 -type d -not -empty -not -name ".*" | while read -r i; do
+ cp -R "$i" "$pkgdir"/usr/share/asteroid-launcher/wallpapers/
done
}
-sha512sums="2fa6770263f7268862e148b08f0a97dd68e0e46191e94feda93aaa04c7b04f85c8d54df22169eb5ba0cb8f06b49cc5b30e7221847dbf63fbdf8938fb86f83f09 asteroid-wallpapers-a748cf9314d5798eb1bf66c3b6641eecd2d3d655.tar.gz"
+sha512sums="
+6acfbb74f7620abfa57acb72f3f044ccec082beb1fb5111bba9256201088ca68d20c1f838c7fda8495afc5462813a07461aff09099129190ad3d11cd84451932 asteroid-wallpapers-2.0.0.tar.gz
+"