aboutsummaryrefslogtreecommitdiffstats
path: root/testing/asymptote/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/asymptote/APKBUILD')
-rw-r--r--testing/asymptote/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/testing/asymptote/APKBUILD b/testing/asymptote/APKBUILD
index 951c7b5a430..a7e631f70cb 100644
--- a/testing/asymptote/APKBUILD
+++ b/testing/asymptote/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Julian Weigt <juw@posteo.de>
# Maintainer: Julian Weigt <juw@posteo.de>
pkgname=asymptote
-pkgver=2.70
+pkgver=2.86
pkgrel=0
pkgdesc="A vector graphics language for technical drawing"
-url="http://asymptote.sourceforge.net/"
-arch="all !mips64 !s390x !riscv64" #blocked by texlive
+url="https://asymptote.sourceforge.net/"
+arch="all !ppc64le !s390x !riscv64" #blocked by texlive
license="GPL-3.0-only"
depends="texlive texlive-dvi ghostscript"
### Optional dependencies
@@ -13,9 +13,11 @@ depends="texlive texlive-dvi ghostscript"
# fftw for fourier transform of data
# numpy pyqt5 cson and librsvg for GUI program xasy. I could not find cson for alpine though.
# freeglut for openGL support
-makedepends="zlib-dev texinfo autoconf"
+makedepends="zlib-dev texinfo autoconf bison flex texmf-dist-latexextra"
subpackages="$pkgname-doc"
-source="https://downloads.sourceforge.net/sourceforge/asymptote/asymptote-$pkgver.src.tgz"
+source="https://downloads.sourceforge.net/sourceforge/asymptote/asymptote-$pkgver.src.tgz
+ fix-nullopt-not-declared.patch
+ "
prepare() {
default_prepare
@@ -48,4 +50,7 @@ package() {
make -j1 DESTDIR="$pkgdir" install-all
}
-sha512sums="24d60af361e3f0309a896ce8163da6fc0a9d6587efe726c5acf874dcb74f4d51b4bad8146a615ff54173ef06dac53117fd1cc09c77940271adc9f64cac6bcfe6 asymptote-2.70.src.tgz"
+sha512sums="
+9e11dbfca10379f07b50dcce0d63c12b793f47741651b1804cf0825e87604c40b5b94acf343ce7f5ca7da83b5ebb0e213090ada80e0b6ebe4f6cec9db67209d6 asymptote-2.86.src.tgz
+54bb8b5d71d5ad663da60f4be9b725a9f00cdaf8dd68326a696683269b3bdcb07ba885d6347643c67159a7a38ec7b3196e7c1617fe99d41a4a1a62b135861fce fix-nullopt-not-declared.patch
+"