aboutsummaryrefslogtreecommitdiffstats
path: root/testing/async-profiler/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/async-profiler/APKBUILD')
-rw-r--r--testing/async-profiler/APKBUILD41
1 files changed, 0 insertions, 41 deletions
diff --git a/testing/async-profiler/APKBUILD b/testing/async-profiler/APKBUILD
deleted file mode 100644
index e05dbc7a037..00000000000
--- a/testing/async-profiler/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Andrey Pustovetov <andrey.pustovetov@gmail.com>
-# Maintainer: Andrey Pustovetov <andrey.pustovetov@gmail.com>
-pkgname=async-profiler
-pkgver=1.5
-pkgrel=0
-pkgdesc="Sampling CPU and HEAP profiler for Java featuring AsyncGetCallTrace + perf_events"
-url="https://github.com/jvm-profiling-tools/async-profiler"
-arch="x86 x86_64"
-depends="bash"
-license="Apache-2.0"
-options="!checkroot" # due to fakeroot the test suite fails
-makedepends="linux-headers openjdk8"
-checkdepends="bash openjdk8-dbg"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jvm-profiling-tools/async-profiler/archive/v$pkgver.tar.gz
- thread-smoke-test_should_do_some_real_work.patch
- "
-
-build() {
- make
-}
-
-check() {
- # exclude tests depended to modify /proc/sys/kernel/perf_event_paranoid
- JAVA_HOME="/usr/lib/jvm/default-jvm" \
- test/alloc-smoke-test.sh
- echo "All tests passed"
-}
-
-package() {
- local homedir="/usr/share/$pkgname"
- local destdir="$pkgdir/$homedir"
- mkdir -p "$destdir"
- install -Dm0644 "$builddir"/build/libasyncProfiler.so "$destdir"/build/libasyncProfiler.so
- install -Dm0755 "$builddir"/build/jattach "$destdir"/build/jattach
- install -Dm0755 "$builddir"/profiler.sh "$destdir"/profiler.sh
- mkdir -p "$pkgdir"/usr/bin
- ln -sf "$homedir"/profiler.sh "$pkgdir"/usr/bin/profiler.sh
-}
-
-sha512sums="a127f6c676e2f06c2690ea04da660e36a5c127dc22b9f2edec801bd1829bcd3fb608572a8e38fcfa1e27067da27b16f77d2cb1fa7848e6afdf4bdda361f47e86 async-profiler-1.5.tar.gz
-180d5a4231eab62399888491ae80338f38f0ebbfbd1157bea2d58bfc1f6c344d9ba144aa87deb11c2143a9df5dd21531fdcf98f2d5d9ce8f715e8caeb2b2ac2e thread-smoke-test_should_do_some_real_work.patch"