aboutsummaryrefslogtreecommitdiffstats
path: root/testing/avdl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/avdl/APKBUILD')
-rw-r--r--testing/avdl/APKBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/testing/avdl/APKBUILD b/testing/avdl/APKBUILD
index bdbb900d715..59ede86eb67 100644
--- a/testing/avdl/APKBUILD
+++ b/testing/avdl/APKBUILD
@@ -1,34 +1,29 @@
# Contributor: Tom Tsagk <tomtsagk@darkdimension.org>
# Maintainer: Tom Tsagk <tomtsagk@darkdimension.org>
pkgname=avdl
-pkgver=0.1.2
-pkgrel=0
+pkgver=0.4.3
+pkgrel=1
pkgdesc="Abstract video-game development language compiler"
url="https://darkdimension.org/avdl.html"
arch="all"
license="GPL-3.0-only"
makedepends="musl-dev glew-dev sdl2-dev sdl2_mixer-dev"
+subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/tomtsagk/avdl/archive/refs/tags/v$pkgver.tar.gz"
-# There is no "-dev" subpackage, as this is a compiler
-subpackages="$pkgname-doc"
+check() {
+ make test
+}
build() {
- # compiles the project, to be potentially
- # placed in /usr (when installed)
make prefix=/usr
}
-# There is currently no check() functionality
-# as there are no tests for this project yet.
-
package() {
-
- # stage the installation in "$pkgdir"
make DESTDIR="$pkgdir" prefix=/usr install
}
sha512sums="
-fcb368e8740f92067d25cb81f7311ab0e2522d4efea874dc90a7db67eaeb79c1d7a8228ae380f7ffee10d61fe6c80314a135584a64d4a4e2c0460c1726be978e avdl-0.1.2.tar.gz
+0c0f4b80810ff8575169fce3601cd93813f9e54763d0e4b4b3d447204b8560b17a34d3f69ed861a6712841abb5fc1426868f175b84008054d95b5c26fb024faf avdl-0.4.3.tar.gz
"