aboutsummaryrefslogtreecommitdiffstats
path: root/testing/b3sum/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/b3sum/APKBUILD')
-rw-r--r--testing/b3sum/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/testing/b3sum/APKBUILD b/testing/b3sum/APKBUILD
deleted file mode 100644
index 4065d331b43..00000000000
--- a/testing/b3sum/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
-pkgname=b3sum
-pkgver=0.3.8
-pkgrel=0
-pkgdesc="Command line implementation of the BLAKE3 hash function"
-url="https://blake3.io"
-arch="all !s390x !armhf !mips !mips64" # armhf: 'vaddq_u32': target specific option mismatch
-license="CC0-1.0 OR Apache-2.0"
-makedepends="cargo"
-source="b3sum-$pkgver.tar.gz::https://crates.io/api/v1/crates/b3sum/$pkgver/download"
-
-case "$CARCH" in
- arm*) _features="neon" ;;
-esac
-
-build() {
- cargo build --release --locked --no-default-features ${_features:+--features="$_features"}
-}
-
-check() {
- cargo test --release --locked --no-default-features ${_features:+--features="$_features"}
-}
-
-package() {
- cargo install --path . --root="$pkgdir/usr" --no-default-features ${_features:+--features "$_features"}
- rm "$pkgdir"/usr/.crates*
-}
-
-sha512sums="
-ae4e9f8bb035224afc1127f00d5f83567dea082a9b243cc8a024831ad4867278a2afb48fd5f64d60e1002ec12d446c9c9925523f1798f1006f4e07bd615e1afd b3sum-0.3.8.tar.gz
-"