aboutsummaryrefslogtreecommitdiffstats
path: root/testing/barman/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/barman/APKBUILD')
-rw-r--r--testing/barman/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/testing/barman/APKBUILD b/testing/barman/APKBUILD
index 8cb6fd893ef..48154d3329d 100644
--- a/testing/barman/APKBUILD
+++ b/testing/barman/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=barman
-pkgver=2.17
+pkgver=3.10.0
pkgrel=0
pkgdesc="Backup and recovery manager for PostgreSQL"
-url="http://www.pgbarman.org"
-arch="noarch !mips64" # blocked by py3-boto3
+url="https://pgbarman.org"
+arch="noarch"
license="GPL-3.0-or-later"
-depends="python3 rsync py3-argcomplete py3-dateutil py3-psycopg2 py3-argh py3-boto3"
-makedepends="py3-setuptools"
-subpackages="$pkgname-doc $pkgname-bash-completion"
+depends="python3 rsync postgresql-client py3-argcomplete py3-dateutil py3-psycopg2 py3-boto3"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-doc $pkgname-bash-completion $pkgname-pyc"
pkgusers="barman"
pkggroups="barman"
install="$pkgname.pre-install"
@@ -18,20 +18,22 @@ checkdepends="py3-pytest-timeout py3-mock py3-pytest-runner py3-pip py3-mock"
source="$pkgname-$pkgver.tar.gz::https://github.com/EnterpriseDB/barman/releases/download/release/$pkgver/barman-$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
install -Dm0644 ./scripts/barman.bash_completion \
"$pkgdir"/usr/share/bash-completion/completions/$pkgname
install -d -o $pkgusers -g $pkggroups -m 755 "$pkgdir"/var/log/$pkgname
cd doc
- install -Dm0644 barman.conf -t "$pkgdir/etc/barman.d/main.conf"
+ install -Dm0644 barman.conf -t "$pkgdir/etc"
}
sha512sums="
-87d91dc75102cf1f61d7db166420fbc3db44d32f16f6f662b1b8118f91dc30ced30d090db927a91bfa9f39a6de36c8716123fc5e39e6d278d99f5f62e269d224 barman-2.17.tar.gz
+84bdd314ee336b1e0863f42be071927da6d333e9a31655a69444c9922310d78f03d1a2a64a36565dc4f3469a33b0d2286ece796aa22b760e97e0610ce51aed25 barman-3.10.0.tar.gz
"