aboutsummaryrefslogtreecommitdiffstats
path: root/testing/belle-sip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/belle-sip/APKBUILD')
-rw-r--r--testing/belle-sip/APKBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/testing/belle-sip/APKBUILD b/testing/belle-sip/APKBUILD
index 5f8194d8b2a..4bbf77a4418 100644
--- a/testing/belle-sip/APKBUILD
+++ b/testing/belle-sip/APKBUILD
@@ -1,38 +1,44 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=belle-sip
-pkgver=5.0.55
+pkgver=5.3.38
pkgrel=0
pkgdesc="SIP (RFC3261) implementation written in C"
-url="https://www.linphone.org"
-arch="all !mips !mips64 !riscv64" # java
+url="https://www.linphone.org/"
+arch="all !riscv64" # java
license="GPL-2.0-or-later"
options="!check" # no test available
makedepends="cmake libantlr3c libantlr3c-dev bctoolbox-dev
-zlib-dev mbedtls-dev java-jre-headless belr-dev"
+zlib-dev mbedtls-dev java-jre-headless belr-dev samurai"
subpackages="$pkgname-dev"
source="https://gitlab.linphone.org/BC/public/belle-sip/-/archive/$pkgver/belle-sip-$pkgver.tar.gz
antlr.jar::https://github.com/antlr/website-antlr3/blob/gh-pages/download/antlr-3.4-complete.jar?raw=true"
+# unversioned provider of java-jre-headless needs to be selected explicitly
+case "$CARCH" in
+armv7|armhf|x86)
+ makedepends="$makedepends openjdk8-jre-base"
+ ;;
+esac
+
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_MODULE_PATH=/usr/lib/cmake \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DENABLE_STATIC=NO \
- -DENABLE_SHARED=YES \
- -DENABLE_TESTS=NO \
- -DENABLE_STRICT=NO \
- -DANTLR3_JAR_PATH="$srcdir"/antlr.jar
- make -C build
+ -DBUILD_SHARED_LIBS=YES \
+ -DENABLE_UNIT_TESTS=NO \
+ -DENABLE_STRICT=NO
+ cmake --build build
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-83810c4eaeda2b456de977a4f034f37f5c3c1a8a220ae0d0af8c2d33bb1e19a2a6feb2c5a3af86db20301d1c7002faef0935d196ca24a663d54740da691c0e3d belle-sip-5.0.55.tar.gz
+bb6143c2ac7b8551d58f4c15076dbb56405cc653e50030a7d7208d27401658fe199bdb65332dbfbece5a68f93957140b59def88777e7abf6222550c192be7c2c belle-sip-5.3.38.tar.gz
04be4dfba3a21f3ab9d9e439a64958bd8e844a9f151b798383bd9e0dd6ebc416783ae7cb1d1dbb27fb7288ab9756b13b8338cdb8ceb41a10949c852ad45ab1f2 antlr.jar
"