aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bitlbee-mastodon
diff options
context:
space:
mode:
Diffstat (limited to 'testing/bitlbee-mastodon')
-rw-r--r--testing/bitlbee-mastodon/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/bitlbee-mastodon/APKBUILD b/testing/bitlbee-mastodon/APKBUILD
new file mode 100644
index 00000000000..9d5dad131f5
--- /dev/null
+++ b/testing/bitlbee-mastodon/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Marvin Steadfast <marvin@xsteadfastx.org>
+# Maintainer: Marvin Steadfast <marvin@xsteadfastx.org>
+pkgname=bitlbee-mastodon
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="Mastodon plugin for Bitlbee"
+url="https://alexschroeder.ch/cgit/bitlbee-mastodon"
+arch="all"
+license="LGPL-2.1"
+depends="bitlbee"
+makedepends="bitlbee-dev autoconf automake libtool"
+source="bitlbee-mastodon-$pkgver.tar.gz::https://github.com/kensanata/bitlbee-mastodon/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ ./autogen.sh
+}
+
+build() {
+ cd "$builddir"
+ ./configure
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="14802913b42f22af93de024325296616d42cd3f78b9c94d5f807671cbc735f9b07a976838e7d6917b88628a9042966b0a1749b9759a4a58bfa6c0917377f4e47 bitlbee-mastodon-1.3.1.tar.gz"