aboutsummaryrefslogtreecommitdiffstats
path: root/testing/blocky/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/blocky/APKBUILD')
-rw-r--r--testing/blocky/APKBUILD33
1 files changed, 0 insertions, 33 deletions
diff --git a/testing/blocky/APKBUILD b/testing/blocky/APKBUILD
deleted file mode 100644
index 70d81387966..00000000000
--- a/testing/blocky/APKBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Contributor: Justin Berthault <justin.berthault@zaclys.net>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
-pkgname=blocky
-pkgver=0.16
-pkgrel=0
-pkgdesc="DNS proxy as ad-blocker for local network"
-url="https://github.com/0xERR0R/blocky"
-license="Apache-2.0"
-arch="all"
-options="net"
-makedepends="go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/0xERR0R/blocky/archive/v$pkgver.tar.gz"
-
-build() {
- go get github.com/swaggo/swag/cmd/swag@v1.6.5
- make build
-}
-
-check() {
- make test
-}
-
-package() {
- install -Dm755 "bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
-
- # blocky will not start if its log directory is missing
- mkdir -p "$pkgdir"/var/log/blocky
-
-}
-
-sha512sums="
-cb6d691d39307d5515c008e009df220adaf138421d2c7376ee18dba2dae852d978c67a4881e7f1ea5e5f06be704e47169146e63bb86ced74e4791694bfb36d7a blocky-0.16.tar.gz
-"