aboutsummaryrefslogtreecommitdiffstats
path: root/testing/blocky/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/blocky/APKBUILD')
-rw-r--r--testing/blocky/APKBUILD27
1 files changed, 0 insertions, 27 deletions
diff --git a/testing/blocky/APKBUILD b/testing/blocky/APKBUILD
deleted file mode 100644
index c9f1305ba1c..00000000000
--- a/testing/blocky/APKBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Contributor: Justin Berthault <justin.berthault@zaclys.net>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
-pkgname=blocky
-pkgver=0.10
-pkgrel=0
-pkgdesc="DNS proxy as ad-blocker for local network"
-url="https://github.com/0xERR0R/blocky"
-arch="all !mips !mips64"
-license="Apache-2.0"
-options="net"
-makedepends="go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/0xERR0R/blocky/archive/v$pkgver.tar.gz"
-
-build() {
- go get github.com/swaggo/swag/cmd/swag@v1.6.5
- make build
-}
-
-check() {
- make test
-}
-
-package() {
- install -Dm755 "bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
-}
-
-sha512sums="ffa2b41d4573179b38159bcc6c0067ebf86903f7a6bee60ec694ea7eff02bacac571979cdf70c8783bf5a57c04bff0652fdde602a38969fd5f0254688d4056f2 blocky-0.10.tar.gz"