aboutsummaryrefslogtreecommitdiffstats
path: root/testing/buildcache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/buildcache/APKBUILD')
-rw-r--r--testing/buildcache/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/buildcache/APKBUILD b/testing/buildcache/APKBUILD
index dc71997a039..1168ef8d8f3 100644
--- a/testing/buildcache/APKBUILD
+++ b/testing/buildcache/APKBUILD
@@ -1,17 +1,20 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=buildcache
-pkgver=0.27.6
+pkgver=0.28.9
pkgrel=0
pkgdesc="Advanced compiler accelerator"
-url="https://github.com/mbitsnbites/buildcache"
+url="https://gitlab.com/bits-n-bites/buildcache"
arch="all !s390x !armhf" # failing tests
license="Zlib"
makedepends="
- openssl-dev
+ openssl-dev>3
cmake
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mbitsnbites/buildcache/archive/refs/tags/v$pkgver.tar.gz"
+source="https://gitlab.com/bits-n-bites/buildcache/-/archive/v$pkgver/buildcache-v$pkgver.tar.gz
+ include-cstdint.patch
+ "
+builddir="$srcdir/$pkgname-v$pkgver"
build() {
cmake \
@@ -32,5 +35,6 @@ package() {
}
sha512sums="
-7160bef0da93fe2a335b3597ba4adbc58508a6488b703012c80561ffd478f384f4deb32ab676047aa2eb0cd444f0bc785830e850f0b6cf7037f3a3b82608967e buildcache-0.27.6.tar.gz
+be543f0fa7550fedad62efbfc90a522d21276f0379fb836b758d775a95e9a0c6c872b397167a129c8d472a03324081cb7d46d6fdc6c7d369a6594fa64358d2f3 buildcache-v0.28.9.tar.gz
+c57f6c09cbea6e2781e7d71c58e25659dfb9150779afbadc3a0e4c52de531cc5ecc3094b2b0b9571a0f2542453221c53ca54ed65f7492938d1112fae417c3f36 include-cstdint.patch
"