aboutsummaryrefslogtreecommitdiffstats
path: root/testing/captagent
diff options
context:
space:
mode:
Diffstat (limited to 'testing/captagent')
-rw-r--r--testing/captagent/0001-Define-PATH_MAX-if-not-defined.patch30
-rw-r--r--testing/captagent/APKBUILD8
2 files changed, 32 insertions, 6 deletions
diff --git a/testing/captagent/0001-Define-PATH_MAX-if-not-defined.patch b/testing/captagent/0001-Define-PATH_MAX-if-not-defined.patch
new file mode 100644
index 00000000000..27de02c9aa2
--- /dev/null
+++ b/testing/captagent/0001-Define-PATH_MAX-if-not-defined.patch
@@ -0,0 +1,30 @@
+From 15fc71cc82f2dc93321b60d557efdc968f5d9433 Mon Sep 17 00:00:00 2001
+From: Breno Leitao <breno.leitao@gmail.com>
+Date: Tue, 9 May 2017 16:54:49 +0000
+Subject: [PATCH] Define PATH_MAX if not defined
+
+On systems without glibc, you might lack definition of PATH_MAX.
+Defining it as already defined it for interface_http.c as defined in
+civetweb.c.
+---
+ src/modules/interface/http/interface_http.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/modules/interface/http/interface_http.c b/src/modules/interface/http/interface_http.c
+index 5c71e8e..4686c89 100644
+--- a/src/modules/interface/http/interface_http.c
++++ b/src/modules/interface/http/interface_http.c
+@@ -53,6 +53,10 @@
+ #include <json.h>
+ #endif
+
++#ifndef PATH_MAX
++#define PATH_MAX 4096
++#endif
++
+ #include <captagent/globals.h>
+ #include <captagent/api.h>
+ #include <captagent/structure.h>
+--
+2.12.2
+
diff --git a/testing/captagent/APKBUILD b/testing/captagent/APKBUILD
index 46470629830..ca7ac7bad35 100644
--- a/testing/captagent/APKBUILD
+++ b/testing/captagent/APKBUILD
@@ -10,6 +10,7 @@ license="GPL3"
makedepends="autoconf automake bison expat-dev flex flex-dev json-c-dev libtool libpcap-dev linux-headers"
source="$pkgname-$pkgver.tar.gz::https://github.com/sipcapture/captagent/archive/$pkgver.tar.gz
$pkgname.initd
+ 0001-Define-PATH_MAX-if-not-defined.patch
ac-fix.patch"
builddir="$srcdir/$pkgname-$pkgver"
@@ -29,12 +30,7 @@ package() {
rm "$pkgdir"/usr/lib/$pkgname/modules/*.a
}
-md5sums="8c7f73d37776a7dbc616aa3217f824a3 captagent-6.1.0.20.tar.gz
-e1b4e439f41550dd643072a4b0286f86 captagent.initd
-43eddea9f2c3c0efa658b3cbe64e4e48 ac-fix.patch"
-sha256sums="64def81f3b53b16416fcc7e8cb61136c53e8b25446403287b0bb6e6b27089713 captagent-6.1.0.20.tar.gz
-1d8843def6b13dc575bf8c1403cf637248b2e61f4314d62c9e3b8585ec6ff1ae captagent.initd
-f42aec59c15ef8a8adbfd7221318e0d8a48fb5d95a5252f8332f2192cbb235fb ac-fix.patch"
sha512sums="b867a41dfe98015f01fa8c67e57214754231eeec40d0685983fca9aacf53cc5287c2c9959f4752c80004ad5abc2e8a96058797b6b7cdc259a48443c1a909b609 captagent-6.1.0.20.tar.gz
750326291fc65fa9a3568f6961f2d6b950baa715e75ad7fc8263956cc91c50445e2e041d8f73675a350ba0d55786908564b439396376d8105fb69332e8aefc27 captagent.initd
+f7c04f5e273dd362f09fd1e6a605f56dcaf64c71cd0d6ba16dadaca5e005b1f29dccd81b186c3727d2fc7872bd684ca4ddc8fc7a2a36fd83956592a134ea6a37 0001-Define-PATH_MAX-if-not-defined.patch
c0bbbbf2f96c7644b154e71b672af5a0d7c209dd5b309b6f6b35915a04f30a33ff4fc18e408e3f1641d4ca6ae51430f9ac0189984f828353263fb52e985b47c1 ac-fix.patch"