aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cgal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cgal/APKBUILD')
-rw-r--r--testing/cgal/APKBUILD29
1 files changed, 0 insertions, 29 deletions
diff --git a/testing/cgal/APKBUILD b/testing/cgal/APKBUILD
deleted file mode 100644
index 90f7d5aafc7..00000000000
--- a/testing/cgal/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-pkgname=cgal
-pkgver=4.14
-pkgrel=6
-pkgdesc="Efficient and reliable geometric algorithms as C++ library"
-url="https://www.cgal.org/"
-arch="all"
-license="GPL-3.0-or-later custom" # Dual licensed under GPL-3.0+ and commercial
-subpackages="$pkgname-dev $pkgname-doc"
-makedepends="mpfr-dev gmp-dev mesa-dev glu-dev boost-dev cmake zlib-dev"
-source="https://github.com/CGAL/cgal/releases/download/releases%2FCGAL-$pkgver/CGAL-$pkgver.tar.xz"
-builddir="$srcdir/CGAL-$pkgver"
-# Citing from.https://github.com/CGAL/cgal/wiki/Testing#test-suite-directory
-# > The test/ directory is not part of external releases.
-options="!check"
-
-build() {
- mkdir -p build
- cd build
- cmake ../ -DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
- make
-}
-
-package() {
- cd build
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="1f22da098a136c26fd51c7ac401212865dce7cc5110ca6a083ef6f09ead5c03a002bfd16752cb298427b84bd5b4900b52c6514f97ccd0e199ffb28e9fe640c43 CGAL-4.14.tar.xz"