aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cherrytree/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cherrytree/APKBUILD')
-rw-r--r--testing/cherrytree/APKBUILD63
1 files changed, 40 insertions, 23 deletions
diff --git a/testing/cherrytree/APKBUILD b/testing/cherrytree/APKBUILD
index 13537a21f8e..642f2c005fa 100644
--- a/testing/cherrytree/APKBUILD
+++ b/testing/cherrytree/APKBUILD
@@ -1,30 +1,36 @@
# Contributor: Alex Yam <alex@alexyam.com>
# Maintainer: Alex Yam <alex@alexyam.com>
pkgname=cherrytree
-pkgver=0.99.30
-pkgrel=1
+pkgver=1.1.2
+pkgrel=0
pkgdesc="hierarchical note taking application featuring rich text and syntax highlighting"
url="https://github.com/giuspen/cherrytree"
license="GPL-3.0-or-later"
-# mips64, s390x: libxml++2.6 missing
-arch="all !mips64 !s390x"
-makedepends="cmake gtkmm3-dev gtksourceviewmm3-dev gspell-dev libxml++-2.6-dev
- sqlite-dev curl-dev uchardet-dev fmt-dev spdlog-dev python3"
+# s390x: libxml++2.6 missing
+arch="all !s390x"
+makedepends="
+ cmake
+ curl-dev
+ fmt-dev
+ gspell-dev
+ gtkmm3-dev
+ gtksourceviewmm3-dev
+ libxml++-2.6-dev
+ python3
+ samurai
+ spdlog-dev
+ sqlite-dev
+ uchardet-dev
+ vte3-dev
+ "
checkdepends="xvfb-run"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://github.com/giuspen/cherrytree/releases/download/$pkgver/cherrytree_$pkgver.tar.xz
- fmt8.patch"
+source="https://github.com/giuspen/cherrytree/releases/download/v$pkgver/cherrytree_$pkgver.tar.xz"
builddir="$srcdir/${pkgname}_$pkgver"
-# Test #19: MiscUtilsGroup.ThreadSafeDEQueue_2 Subprocess aborted***Exception
-case "$CARCH" in
- armhf|armv7|s390x|x86) options="!check" ;;
- riscv64) options="textrels" ;;
-esac
-
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=ON \
@@ -34,18 +40,29 @@ build() {
}
check() {
- # Skip broken ms_clip_convert test:
- # ms_clip_convert: ***Exception: SegFault
- cd build && xvfb-run ctest -E ClipboardGroup.ms_clip_convert
+ # Skip broken ExportsMultipleParametersTests.ChecksExports tests
+ #
+ # (run_tests_with_x_1:7077): Gtk-WARNING **: 04:05:18.849:
+ # Found an icon but could not load it. Most likely gdk-pixbuf does not
+ # provide SVG support.
+ #
+ # [ FAILED ] ExportsTests/ExportsMultipleParametersTests.ChecksExports
+ # /testing/cherrytree/src/cherrytree_0.99.44/tests/data_данные
+ # /test_документ.ctb", "--export_to_html_dir")
+ xvfb-run -a ctest --test-dir build -j $JOBS --output-on-failure \
+ -E ExportsMultipleParametersTests.ChecksExports
}
package() {
DESTDIR="$pkgdir" cmake --build build --target install
- # Remove test files
- rm -rv $pkgdir/usr/include $pkgdir/usr/lib
+
+ # Remove gmock/gtest files
+ rm -rv "$pkgdir"/usr/include "$pkgdir"/usr/lib
+
+ # bundled breeze-icons
+ rm -rv "$pkgdir"/usr/share/cherrytree/icons
}
sha512sums="
-949308a5a1eb2ee722d5f4cc530735b597d6caf1f04c4858903260a8c5eedbdc8431e1988516bb5b4fd425c171bbaa332293d741f0a8e594f6c0276468d2ee22 cherrytree_0.99.30.tar.xz
-edb07386e90acd4be2bae8926c754066f663e5728a7cd900bd3bbf0ac9ee16461a9138d1ae759980c73f5341efb619fb1dc866132c47c505b45fe1e614767604 fmt8.patch
+39d1e765e3a644966a5571580baf7cd33b2ac65a05efebd31bfe7a6b037359f880309806d95e240d78a3f21dd312b7b4decdcd5cc5e50b48935ea3643a9dcf7e cherrytree_1.1.2.tar.xz
"