aboutsummaryrefslogtreecommitdiffstats
path: root/testing/clevis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/clevis/APKBUILD')
-rw-r--r--testing/clevis/APKBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/testing/clevis/APKBUILD b/testing/clevis/APKBUILD
index 7694dc3ed6e..99488ae82f0 100644
--- a/testing/clevis/APKBUILD
+++ b/testing/clevis/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=clevis
-pkgver=18
+pkgver=19
pkgrel=0
pkgdesc="Pluggable framework for automated decryption"
url="https://github.com/latchset/clevis"
license="GPL-3.0-or-later WITH OpenSSL-Exception"
-arch="all !s390x !riscv64" # blocked by udisks2
+arch="all"
depends="bash cryptsetup jose libpwquality"
makedepends="
asciidoc
- bash-completion
+ bash-completion-dev
meson
tpm2-tools
cryptsetup-dev
@@ -20,23 +20,21 @@ makedepends="
udisks2-dev
luksmeta-dev
"
-checkdepends="jq tang"
+checkdepends="jq keyutils tang"
subpackages="
$pkgname-dbg
$pkgname-doc
$pkgname-bash-completion
"
-source="https://github.com/latchset/clevis/archive/v$pkgver/clevis-$pkgver.tar.gz
- musl.patch
- "
+source="https://github.com/latchset/clevis/archive/v$pkgver/clevis-$pkgver.tar.gz"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -44,6 +42,5 @@ package() {
}
sha512sums="
-19b6743ff61ff7e29699bbc3fb69dfa31567a37ab824629330b57c92aa89b70759d63c1770be68d4525681ec9ba56d980cae2bb1cdeee6192992ede449a0e4ff clevis-18.tar.gz
-3ba68e896b58040eaddc50dcdf9fa9a42c0348be4bc9c96d09061563a608b9f77edf21cf159d45ccd95954625496cd3645acccaed8642b360f632201b9a28fd0 musl.patch
+dee19354c908c3843fc295a84b431780d5d6062c77766ee7ce9550636d3623d92b0cd1f6d4c40d57bef14debddc161da2b72289a5d6185cdd17b09a1ef67409a clevis-19.tar.gz
"