aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cliphist/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cliphist/APKBUILD')
-rw-r--r--testing/cliphist/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/testing/cliphist/APKBUILD b/testing/cliphist/APKBUILD
index dc562bcbe77..821b622d276 100644
--- a/testing/cliphist/APKBUILD
+++ b/testing/cliphist/APKBUILD
@@ -1,8 +1,7 @@
-# Contributor: psykose <alice@ayaya.dev>
-# Maintainer: psykose <alice@ayaya.dev>
+# Maintainer:
pkgname=cliphist
-pkgver=0.3.1
-pkgrel=3
+pkgver=0.5.0
+pkgrel=2
pkgdesc="wayland clipboard manager"
url="https://github.com/sentriz/cliphist"
arch="all"
@@ -13,22 +12,26 @@ makedepends="go"
subpackages="$pkgname-fzf::noarch"
source="$pkgname-$pkgver.tar.gz::https://github.com/sentriz/cliphist/archive/refs/tags/v$pkgver.tar.gz"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go build
}
package() {
install -D -m755 cliphist -t "$pkgdir"/usr/bin/
+ install -D -m755 contrib/cliphist-fzf -t "$pkgdir"/usr/bin/
}
fzf() {
pkgdesc="$pkgdesc with fzf picker"
depends="$pkgname=$pkgver-r$pkgrel fzf"
- cd "$builddir"
- install -D -m755 contrib/cliphist-fzf -t "$subpkgdir"/usr/bin/
+ amove usr/bin/cliphist-fzf
}
sha512sums="
-11416933b2c7e11d271f1e618ae8d18e450212bf2ae3e6bc869c1932b5bd25d4b20aea7ef1b78d152b411fdec28b4339cf5d26a5d30a47103606e3ed128d80d2 cliphist-0.3.1.tar.gz
+c1ef41d8efe574850e0a2e77d2d8989e6c17162b4eaef34362ec4f00ec79e5e71a60a9773c452f008e1851665e424a4ef4d3b1aef62338e14134310399be5baa cliphist-0.5.0.tar.gz
"