aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cliphist/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cliphist/APKBUILD')
-rw-r--r--testing/cliphist/APKBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/testing/cliphist/APKBUILD b/testing/cliphist/APKBUILD
index 774274e8700..821b622d276 100644
--- a/testing/cliphist/APKBUILD
+++ b/testing/cliphist/APKBUILD
@@ -1,27 +1,37 @@
-# Contributor: psykose <alice@ayaya.dev>
-# Maintainer: psykose <alice@ayaya.dev>
+# Maintainer:
pkgname=cliphist
-pkgver=0.3.0
-pkgrel=0
+pkgver=0.5.0
+pkgrel=2
pkgdesc="wayland clipboard manager"
url="https://github.com/sentriz/cliphist"
arch="all"
license="GPL-3.0" # does not specify if -only
options="!check net" # no testsuite
-depends="fzf wl-clipboard"
+depends="wl-clipboard"
makedepends="go"
+subpackages="$pkgname-fzf::noarch"
source="$pkgname-$pkgver.tar.gz::https://github.com/sentriz/cliphist/archive/refs/tags/v$pkgver.tar.gz"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go build
}
package() {
- mkdir -p "$pkgdir"/usr/bin
- mv "$builddir"/cliphist "$pkgdir"/usr/bin
- mv "$builddir"/contrib/cliphist-fzf "$pkgdir"/usr/bin
+ install -D -m755 cliphist -t "$pkgdir"/usr/bin/
+ install -D -m755 contrib/cliphist-fzf -t "$pkgdir"/usr/bin/
+}
+
+fzf() {
+ pkgdesc="$pkgdesc with fzf picker"
+ depends="$pkgname=$pkgver-r$pkgrel fzf"
+
+ amove usr/bin/cliphist-fzf
}
sha512sums="
-845d1d9551db155cd29060e6c6740e62132e559141b378b9e4eea4e3824f618c987496a176b0e660b45be39a2354851dd6d812af687b81e59b09de2e312d4767 cliphist-0.3.0.tar.gz
+c1ef41d8efe574850e0a2e77d2d8989e6c17162b4eaef34362ec4f00ec79e5e71a60a9773c452f008e1851665e424a4ef4d3b1aef62338e14134310399be5baa cliphist-0.5.0.tar.gz
"