aboutsummaryrefslogtreecommitdiffstats
path: root/testing/coin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/coin/APKBUILD')
-rw-r--r--testing/coin/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/testing/coin/APKBUILD b/testing/coin/APKBUILD
index ffc0a4a6ab8..782df0b027f 100644
--- a/testing/coin/APKBUILD
+++ b/testing/coin/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=coin
pkgver=4.0.0
-pkgrel=0
+pkgrel=5
pkgdesc="OpenGL OpenInventor compatible graphics library"
url="https://github.com/coin3d/coin"
license="BSD-3-Clause"
arch="all"
-makedepends="boost-dev cmake glu-dev graphviz"
+makedepends="boost-dev cmake glu-dev graphviz samurai"
subpackages="$pkgname-dev"
source="https://github.com/coin3d/coin/releases/download/Coin-$pkgver/coin-$pkgver-src.tar.gz
TestSuitePatch.patch
@@ -15,10 +15,8 @@ source="https://github.com/coin3d/coin/releases/download/Coin-$pkgver/coin-$pkgv
builddir="$srcdir/coin"
build() {
- export CXXFLAGS="${CXXFLAGS/-Os/}" # test suite fails with -Os optimizations
- cmake . \
- -B ./build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCOIN_BUILD_TESTS=ON
cmake --build build