aboutsummaryrefslogtreecommitdiffstats
path: root/testing/coq/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/coq/APKBUILD')
-rw-r--r--testing/coq/APKBUILD72
1 files changed, 55 insertions, 17 deletions
diff --git a/testing/coq/APKBUILD b/testing/coq/APKBUILD
index 1a2167db623..0b283a2d358 100644
--- a/testing/coq/APKBUILD
+++ b/testing/coq/APKBUILD
@@ -1,32 +1,70 @@
# Contributor: alpine-mips-patches <info@mobile-stream.com>
-# Maintainer: alpine-mips-patches <info@mobile-stream.com>
+# Contributor: omni <omni+alpine@hack.org>
+# Contributor: Jason Gross <jasongross9@gmail.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=coq
-pkgver=8.13.2
-pkgrel=0
-pkgdesc="A formal proof management system"
+pkgver=8.19.1
+pkgrel=3
+pkgdesc="Formal proof management system"
url="https://coq.inria.fr"
-arch="aarch64 ppc64le x86_64" # reflect ocaml aport platforms
-license="LGPL-2.1"
-depends="ocaml-runtime"
-makedepends="ocaml ocaml-findlib ocaml-compiler-libs ocaml-zarith dune gmp-dev bash"
-options="!check"
+# riscv64, loongarch64: ocaml
+# s390x: not useful
+# 32-bit: huge package and nobody would use it there
+arch="all !armhf !armv7 !x86 !s390x !riscv64 !loongarch64"
+license="LGPL-2.1-or-later"
+makedepends="
+ bash
+ dune
+ linux-headers
+ ocaml
+ ocaml-compiler-libs
+ ocaml-findlib-dev
+ ocaml-zarith
+ "
+options="!check" # many tests in 'make test-suite' fail
subpackages="$pkgname-doc"
-source="coq-$pkgver.tar.gz::https://github.com/coq/coq/archive/V$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/coq/coq/archive/V$pkgver.tar.gz"
build() {
./configure \
-prefix /usr \
- -coqdocdir /usr/share/texmf-dist/tex/latex/misc \
- -bytecode-compiler no \
- -coqide no \
- -nodebug
- make world
+ -mandir /usr/share/man \
+ -docdir /usr/share/doc \
+ -libdir "$(ocamlc -where)/coq"
+ make dunestrap
+ dune build -p coq,coq-core,coq-stdlib
}
package() {
- make -j1 COQINSTALLPREFIX="$pkgdir" install
+ dune install coq coq-core coq-stdlib \
+ --prefix=/usr \
+ --destdir="$pkgdir" \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc \
+ --libdir="$(ocamlc -where)"
+}
+
+prepare_py_provides() {
+ local datadir="${subpkgdir:-$pkgdir}"
+ local pkgbasedir=${pkgbasedir:-"$startdir/pkg"}
+ local controldir="$pkgbasedir"/.control.${subpkgname:-$pkgname}
+
+ options_has "!tracedeps" && return 0
+
+ ocaml4-abuild-find provides \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir" \
+ "$pkgver-r$pkgrel"
+}
+
+scan_python3_dependency() {
+ local controldir="$2" datadir="$3"
+
+ ocaml4-abuild-find requires \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir"
}
sha512sums="
-d5c16689a3a08d9be58e15d502e5c9bbe13ce8b9755334d1c096307260a804eeb59116c3a7b5fd85910e7f468ee728c69d04735769998a6e6369bf5352f5ec05 coq-8.13.2.tar.gz
+ec8379df34ba6e72bcf0218c66fef248b0e4c5c436fb3f2d7dd83a2c5f349dd0874a67484fcf9c0df3e5d5937d7ae2b2a79274725595b4b0065a381f70769b42 coq-8.19.1.tar.gz
"