aboutsummaryrefslogtreecommitdiffstats
path: root/testing/coq/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/coq/APKBUILD')
-rw-r--r--testing/coq/APKBUILD72
1 files changed, 51 insertions, 21 deletions
diff --git a/testing/coq/APKBUILD b/testing/coq/APKBUILD
index d37c87c022a..0b283a2d358 100644
--- a/testing/coq/APKBUILD
+++ b/testing/coq/APKBUILD
@@ -1,40 +1,70 @@
# Contributor: alpine-mips-patches <info@mobile-stream.com>
# Contributor: omni <omni+alpine@hack.org>
-# Maintainer: alpine-mips-patches <info@mobile-stream.com>
+# Contributor: Jason Gross <jasongross9@gmail.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=coq
-pkgver=8.15.1
-pkgrel=0
-pkgdesc="A formal proof management system"
+pkgver=8.19.1
+pkgrel=3
+pkgdesc="Formal proof management system"
url="https://coq.inria.fr"
-arch="all !riscv64" # limited by ocaml aport
+# riscv64, loongarch64: ocaml
+# s390x: not useful
+# 32-bit: huge package and nobody would use it there
+arch="all !armhf !armv7 !x86 !s390x !riscv64 !loongarch64"
license="LGPL-2.1-or-later"
-depends="ocaml-runtime"
-makedepends="ocaml ocaml-findlib ocaml-compiler-libs ocaml-zarith dune ocaml-num-dev bash"
+makedepends="
+ bash
+ dune
+ linux-headers
+ ocaml
+ ocaml-compiler-libs
+ ocaml-findlib-dev
+ ocaml-zarith
+ "
options="!check" # many tests in 'make test-suite' fail
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/coq/coq/archive/V$pkgver.tar.gz"
-# 32bit archs
-case "$CARCH" in
-armv7|armhf|mips|x86) options="$options textrels" ;;
-esac
-
build() {
./configure \
-prefix /usr \
- -bytecode-compiler no \
- -coqide no
-
- case "$CARCH" in
- s390x) OCAMLPATH=/usr/lib/ocaml CAML_LD_LIBRARY_PATH=/usr/lib/ocaml/zarith/ make -j1;;
- *) OCAMLPATH=/usr/lib/ocaml CAML_LD_LIBRARY_PATH=/usr/lib/ocaml/zarith/ make;;
- esac
+ -mandir /usr/share/man \
+ -docdir /usr/share/doc \
+ -libdir "$(ocamlc -where)/coq"
+ make dunestrap
+ dune build -p coq,coq-core,coq-stdlib
}
package() {
- make -j1 DESTDIR="$pkgdir" install
+ dune install coq coq-core coq-stdlib \
+ --prefix=/usr \
+ --destdir="$pkgdir" \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc \
+ --libdir="$(ocamlc -where)"
+}
+
+prepare_py_provides() {
+ local datadir="${subpkgdir:-$pkgdir}"
+ local pkgbasedir=${pkgbasedir:-"$startdir/pkg"}
+ local controldir="$pkgbasedir"/.control.${subpkgname:-$pkgname}
+
+ options_has "!tracedeps" && return 0
+
+ ocaml4-abuild-find provides \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir" \
+ "$pkgver-r$pkgrel"
+}
+
+scan_python3_dependency() {
+ local controldir="$2" datadir="$3"
+
+ ocaml4-abuild-find requires \
+ "$datadir"/usr/lib/ocaml \
+ "$controldir"
}
sha512sums="
-8ae7bde19b4c098c0fad4206a349c50c7fc2537cbeae68e03d38020fd73f15df46e248b1e7cbbf297c1ccf44f9dd62b1179148588fcb5d397e30141cca954a3c coq-8.15.1.tar.gz
+ec8379df34ba6e72bcf0218c66fef248b0e4c5c436fb3f2d7dd83a2c5f349dd0874a67484fcf9c0df3e5d5937d7ae2b2a79274725595b4b0065a381f70769b42 coq-8.19.1.tar.gz
"