aboutsummaryrefslogtreecommitdiffstats
path: root/testing/coreboot-ectool/fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/coreboot-ectool/fix-makefile.patch')
-rw-r--r--testing/coreboot-ectool/fix-makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/coreboot-ectool/fix-makefile.patch b/testing/coreboot-ectool/fix-makefile.patch
new file mode 100644
index 00000000000..f0ac8a22f5e
--- /dev/null
+++ b/testing/coreboot-ectool/fix-makefile.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile b/Makefile
+index 1ef74d2..94cf3c0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@ CC = gcc
+ WERROR=-Werror
+ CFLAGS = -O2 -Wall -Wextra -Wshadow $(WERROR)
+ PROGRAM = ectool
+-INSTALL = /usr/bin/env install
++INSTALL = /usr/bin/env install -D
+ PREFIX = /usr/local
+ OS_ARCH = $(shell uname)
+
+@@ -22,7 +22,7 @@ $(PROGRAM): ec.o ectool.o
+ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ install: $(PROGRAM)
+- $(INSTALL) $(PROGRAM) $(PREFIX)/sbin
++ $(INSTALL) $(PROGRAM) $(DESTDIR)$(PREFIX)/sbin/$(PROGRAM)
+
+ clean:
+ rm -f *.o $(PROGRAM) junit.xml