aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cri-o/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cri-o/APKBUILD')
-rw-r--r--testing/cri-o/APKBUILD68
1 files changed, 41 insertions, 27 deletions
diff --git a/testing/cri-o/APKBUILD b/testing/cri-o/APKBUILD
index 1c7ef8b2e93..3a21471e5a6 100644
--- a/testing/cri-o/APKBUILD
+++ b/testing/cri-o/APKBUILD
@@ -3,15 +3,14 @@
# Contributor: TBK <alpine@jjtc.eu>
# Maintainer: ungleich <foss@ungleich.ch>
pkgname=cri-o
-pkgver=1.22.0
-pkgrel=1
+pkgver=1.29.1
+pkgrel=2
pkgdesc="OCI-based implementation of Kubernetes Container Runtime Interface"
url="https://github.com/cri-o/cri-o/"
-# mips(64): build errors with dependencies
-arch="all !mips !mips64"
+arch="all"
license="Apache-2.0"
- # Most tests will fail if not ran as root
- # since it tries to create network interfaces
+# Most tests will fail if not ran as root
+# since it tries to create network interfaces
options="net chmod-clean !check"
depends="
cni-plugins
@@ -20,7 +19,7 @@ depends="
containers-common
iproute2
iptables
- runc
+ oci-runtime
"
makedepends="
bash
@@ -34,18 +33,19 @@ makedepends="
libselinux-dev
lvm2-dev
ostree-dev
+ sqlite-dev
tzdata
"
-checkdepends="bats cri-tools jq parallel sudo"
+checkdepends="bats cri-tools jq parallel sudo conmon"
subpackages="
$pkgname-doc
$pkgname-bash-completion
$pkgname-zsh-completion
$pkgname-fish-completion
- $pkgname-contrib-cni:contrib_cni:noarch
$pkgname-openrc
"
-source="https://github.com/cri-o/cri-o/archive/v$pkgver/cri-o-$pkgver.tar.gz
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/cri-o/cri-o/archive/v$pkgver/cri-o-$pkgver.tar.gz
crio.conf
crio.initd
crio.logrotated
@@ -55,11 +55,22 @@ source="https://github.com/cri-o/cri-o/archive/v$pkgver/cri-o-$pkgver.tar.gz
remove-systemd-files.patch
"
+# secfixes:
+# 1.23.2-r0:
+# - CVE-2022-0811
+# 1.24.1-r0:
+# - CVE-2022-1708
+# 1.26.2-r0:
+# - CVE-2022-4318
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+export GOBIN="$GOPATH/bin"
+
build() {
- export GOPATH="$srcdir"
- export GOBIN="$GOPATH/bin"
# https://github.com/cri-o/cri-o/blob/master/install.md#build-tags
- make BUILDTAGS="seccomp selinux containers_image_openpgp containers_image_ostree_stub"
+ make BUILDTAGS="libsqlite3 seccomp selinux apparmor containers_image_openpgp containers_image_ostree_stub"
}
check() {
@@ -67,30 +78,33 @@ check() {
}
package() {
- make DESTDIR="$pkgdir" PREFIX=/usr CRICTL_CONFIG_DIR="/etc/crio" OCIUMOUNTINSTALLDIR="/etc/crio" install
+ make \
+ DESTDIR="$pkgdir" \
+ PREFIX=/usr \
+ CRICTL_CONFIG_DIR="/etc/crio" \
+ OCIUMOUNTINSTALLDIR="/etc/crio" \
+ FISHINSTALLDIR=/usr/share/fish/vendor_completions.d \
+ install.bin-nobuild install.man-nobuild install.completions install.config-nobuild
# We want it in etc so apk does not overwrite it
mkdir -p "$pkgdir"/usr/share/oci-umount/oci-umount.d/
- ln -sf /etc/crio/crio-umount.conf "$pkgdir"/usr/share/oci-umount/oci-umount.d/crio-umount.conf
+ ln -sf ../../../../etc/crio/crio-umount.conf "$pkgdir"/usr/share/oci-umount/oci-umount.d/crio-umount.conf
+
+ # The CNI plugins are recommended to be installed as examples
+ install -Dm644 contrib/cni/*.conflist -t "$pkgdir"/usr/share/doc/cri-o/examples/cni/
install -Dm755 "$srcdir"/crio.initd "$pkgdir"/etc/init.d/crio
install -Dm644 "$srcdir"/crio.conf "$pkgdir"/etc/crio/crio.conf
install -Dm644 "$srcdir"/crio.logrotated "$pkgdir"/etc/logrotate.d/crio
}
-contrib_cni() {
- pkgdesc="$pkgname contrib cni config files"
- mkdir -p "$subpkgdir"/etc/cni/net.d
- cp "$builddir"/contrib/cni/*.conf "$subpkgdir"/etc/cni/net.d
-}
-
sha512sums="
-2b72115ec63354c5b4fae17e2f51ede85d1975e539a8264e60bbeba36b804e6bca030ca2d11579bad8eb6e09746e83268fe0ee2deaae55e3efd4848dc8d206ff cri-o-1.22.0.tar.gz
-e026f056ed92489413e16ed7955a9dcd7d1f4df1cc28e3ea785771b44d43811fea4f5b953cc46bc0c4aeac8ad07115bfff304d7516ebd24f2e58fe782ff812c8 crio.conf
-29561e95398975748236217bbd9df64997f6e3de6c0555d007306bd0535895a648368385a13079eb7d52c06249a91980523a73b6563e86d0575d9cd9c3fa4ee9 crio.initd
+58b01efb166ac74bdc4e17046010f5546b494fb8157e5269323520de2c5e971272c23090e22712d452081eba651ef6e1f2c228def135cdcde943e9aee0225b08 cri-o-1.29.1.tar.gz
+1f60719677295c9c5c615eb25d9159bde0af68a132eee67747f57fe76642d457c98c896c6189f85637d7b4ac24ba55fd9eaeb1699f43c3c5077b645f72a479fb crio.conf
+26048a219bc426ef4a4f50e96d6e0ded1c55dc8415df9a2773764d2ebcb3d9e91077b2916da1ff32674ca4a53062e41e185503d671dacc3167a018b0066347e1 crio.initd
1115228546a696eeebeb6d4b3e5c3152af0c99a2559097fc5829d8b416d979c457b4b1789e0120054babf57f585d3f63cbe49949d40417ae7aab613184bf4516 crio.logrotated
0a567dfa431ab1e53f2a351689be8d588a60cc5fcdbda403ec4f8b6ab9b1c18ad425f6c47f9a5ab1491e3a61a269dc4efa6a59e91e7521fa2b6bb165074aa8e0 cni-plugins-path.patch
-f9577aa7b1c90c6809010e9e406e65092251b6e82f6a0adbc3633290aa35f2a21895e1a8b6ba4b6375dcad3e02629b49a34ab16387e1c36eeb32c8f4dac74706 makefile-fix-install.patch
-26ed10b478feb19cb11f5916b24301943f9e316fdd62d53ec310bb05ffcf4213ceece1340d2486461557abb04074e85002b11b6347fddaaa45ad7439e907a5a7 fix-test.patch
-78c150f87027de489289596371dce0465159ced0758776b445deb58990e099de9c654406183c9da3cc909878b24d28db62121b7056cd180a6f2820e79e165cc6 remove-systemd-files.patch
+09025bff1fed5004a15696cbc7c63260ae7c206ffe2c8506e6063e8889b7aa98bd5c7df2f0c109860d8432ddf5f3b6326dbfd46589d05cf87f26c38e4bdadb9c makefile-fix-install.patch
+b0fdaf2280968a69e05ef72288bbf6fc03787616c6b6fca1e4398f9849167f4773e5e6e72bf1738d1fff2a84e97aa00f23aabcd50898ba8ed130969f50363006 fix-test.patch
+ae7e4a43f18076f19f3ae37d7302bfdf7a3befadf33e46bc9b1b14d50b605e8ba0d06d479568c24e8bf68f17c80ae48798068b2a46c3bcab565a5d225779f30e remove-systemd-files.patch
"