aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cri-o/makefile-fix-install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cri-o/makefile-fix-install.patch')
-rw-r--r--testing/cri-o/makefile-fix-install.patch34
1 files changed, 6 insertions, 28 deletions
diff --git a/testing/cri-o/makefile-fix-install.patch b/testing/cri-o/makefile-fix-install.patch
index 3b1558d48cc..82bb1889229 100644
--- a/testing/cri-o/makefile-fix-install.patch
+++ b/testing/cri-o/makefile-fix-install.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -8,11 +8,11 @@
+@@ -9,11 +9,11 @@
PROJECT := github.com/cri-o/cri-o
CRIO_INSTANCE := crio_dev
@@ -14,24 +14,22 @@
ETCDIR_CRIO ?= ${ETCDIR}/crio
DATAROOTDIR ?= ${PREFIX}/share/containers
BUILDTAGS ?= containers_image_ostree_stub \
-@@ -24,7 +24,7 @@
- $(shell hack/openpgp_tag.sh) \
+@@ -26,7 +26,7 @@
$(shell hack/seccomp_tag.sh) \
- $(shell hack/selinux_tag.sh)
+ $(shell hack/selinux_tag.sh) \
+ $(shell hack/libsubid_tag.sh)
-CRICTL_CONFIG_DIR=${DESTDIR}/etc
+CRICTL_CONFIG_DIR = /etc
CONTAINER_RUNTIME ?= podman
BUILD_PATH := $(shell pwd)/build
BUILD_BIN_PATH := ${BUILD_PATH}/bin
-@@ -436,71 +436,73 @@
- install: .gopathok install.bin install.man install.completions install.systemd install.config
+@@ -420,60 +420,62 @@
+ install: install.bin install.man install.completions install.systemd install.config
install.bin-nobuild:
- install ${SELINUXOPT} -D -m 755 bin/crio $(BINDIR)/crio
-- install ${SELINUXOPT} -D -m 755 bin/crio-status $(BINDIR)/crio-status
- install ${SELINUXOPT} -D -m 755 bin/pinns $(BINDIR)/pinns
+ install ${SELINUXOPT} -D -m 755 bin/crio ${DESTDIR}$(BINDIR)/crio
-+ install ${SELINUXOPT} -D -m 755 bin/crio-status ${DESTDIR}$(BINDIR)/crio-status
+ install ${SELINUXOPT} -D -m 755 bin/pinns ${DESTDIR}$(BINDIR)/pinns
install.bin: binaries install.bin-nobuild
@@ -70,35 +68,23 @@
- install ${SELINUXOPT} -D -m 644 -t ${BASHINSTALLDIR} completions/bash/crio
- install ${SELINUXOPT} -D -m 644 -t ${FISHINSTALLDIR} completions/fish/crio.fish
- install ${SELINUXOPT} -D -m 644 -t ${ZSHINSTALLDIR} completions/zsh/_crio
-- install ${SELINUXOPT} -D -m 644 -t ${BASHINSTALLDIR} completions/bash/crio-status
-- install ${SELINUXOPT} -D -m 644 -t ${FISHINSTALLDIR} completions/fish/crio-status.fish
-- install ${SELINUXOPT} -D -m 644 -t ${ZSHINSTALLDIR} completions/zsh/_crio-status
+ install ${SELINUXOPT} -d -m 755 ${DESTDIR}${BASHINSTALLDIR}
+ install ${SELINUXOPT} -d -m 755 ${DESTDIR}${FISHINSTALLDIR}
+ install ${SELINUXOPT} -d -m 755 ${DESTDIR}${ZSHINSTALLDIR}
+ install ${SELINUXOPT} -D -m 644 -t ${DESTDIR}${BASHINSTALLDIR} completions/bash/crio
+ install ${SELINUXOPT} -D -m 644 -t ${DESTDIR}${FISHINSTALLDIR} completions/fish/crio.fish
+ install ${SELINUXOPT} -D -m 644 -t ${DESTDIR}${ZSHINSTALLDIR} completions/zsh/_crio
-+ install ${SELINUXOPT} -D -m 644 -t ${DESTDIR}${BASHINSTALLDIR} completions/bash/crio-status
-+ install ${SELINUXOPT} -D -m 644 -t ${DESTDIR}${FISHINSTALLDIR} completions/fish/crio-status.fish
-+ install ${SELINUXOPT} -D -m 644 -t ${DESTDIR}${ZSHINSTALLDIR} completions/zsh/_crio-status
install.systemd:
- install ${SELINUXOPT} -D -m 644 contrib/systemd/crio.service $(PREFIX)/lib/systemd/system/crio.service
-- ln -sf crio.service $(PREFIX)/lib/systemd/system/cri-o.service
-- install ${SELINUXOPT} -D -m 644 contrib/systemd/crio-shutdown.service $(PREFIX)/lib/systemd/system/crio-shutdown.service
- install ${SELINUXOPT} -D -m 644 contrib/systemd/crio-wipe.service $(PREFIX)/lib/systemd/system/crio-wipe.service
+ install ${SELINUXOPT} -D -m 644 contrib/systemd/crio.service ${DESTDIR}$(PREFIX)/lib/systemd/system/crio.service
-+ ln -sf crio.service ${DESTDIR}$(PREFIX)/lib/systemd/system/cri-o.service
-+ install ${SELINUXOPT} -D -m 644 contrib/systemd/crio-shutdown.service ${DESTDIR}$(PREFIX)/lib/systemd/system/crio-shutdown.service
+ install ${SELINUXOPT} -D -m 644 contrib/systemd/crio-wipe.service ${DESTDIR}$(PREFIX)/lib/systemd/system/crio-wipe.service
uninstall:
- rm -f $(BINDIR)/crio
-- rm -f $(BINDIR)/crio-status
- rm -f $(BINDIR)/pinns
+ rm -f $(DESTDIR)$(BINDIR)/crio
-+ rm -f $(DESTDIR)$(BINDIR)/crio-status
+ rm -f $(DESTDIR)$(BINDIR)/pinns
for i in $(filter %.5,$(MANPAGES)); do \
- rm -f $(MANDIR)/man5/$$(basename $${i}); \
@@ -111,11 +97,7 @@
- rm -f ${BASHINSTALLDIR}/crio
- rm -f ${FISHINSTALLDIR}/crio.fish
- rm -f ${ZSHINSTALLDIR}/_crio
-- rm -f ${BASHINSTALLDIR}/crio-status
-- rm -f ${FISHINSTALLDIR}/crio-status.fish
-- rm -f ${ZSHINSTALLDIR}/_crio-status
- rm -f $(PREFIX)/lib/systemd/system/crio-wipe.service
-- rm -f $(PREFIX)/lib/systemd/system/crio-shutdown.service
- rm -f $(PREFIX)/lib/systemd/system/crio.service
- rm -f $(PREFIX)/lib/systemd/system/cri-o.service
- rm -rf $(DATAROOTDIR)/oci/hooks.d
@@ -126,11 +108,7 @@
+ rm -f $(DESTDIR)${BASHINSTALLDIR}/crio
+ rm -f $(DESTDIR)${FISHINSTALLDIR}/crio.fish
+ rm -f $(DESTDIR)${ZSHINSTALLDIR}/_crio
-+ rm -f $(DESTDIR)${BASHINSTALLDIR}/crio-status
-+ rm -f $(DESTDIR)${FISHINSTALLDIR}/crio-status.fish
-+ rm -f $(DESTDIR)${ZSHINSTALLDIR}/_crio-status
+ rm -f $(DESTDIR)$(PREFIX)/lib/systemd/system/crio-wipe.service
-+ rm -f $(DESTDIR)$(PREFIX)/lib/systemd/system/crio-shutdown.service
+ rm -f $(DESTDIR)$(PREFIX)/lib/systemd/system/crio.service
+ rm -f $(DESTDIR)$(PREFIX)/lib/systemd/system/cri-o.service
+ rm -f $(DESTDIR)$(ETCDIR_CRIO)/crio.conf