aboutsummaryrefslogtreecommitdiffstats
path: root/testing/crun
diff options
context:
space:
mode:
Diffstat (limited to 'testing/crun')
-rw-r--r--testing/crun/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/crun/APKBUILD b/testing/crun/APKBUILD
new file mode 100644
index 00000000000..bb95ad754fa
--- /dev/null
+++ b/testing/crun/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: kohnish <kohnish@gmx.com>
+# Maintainer: kohnish <kohnish@gmx.com>
+pkgname="crun"
+pkgver="0.11"
+pkgrel=0
+pkgdesc="crun is a command line utility that performs various operations on container images and image repositories."
+url="https://github.com/containers/crun"
+arch="all"
+license="GPL-3.0-only"
+makedepends="libcap-dev libseccomp-dev yajl-dev argp-standalone python3 go-md2man"
+subpackages="$pkgname-doc $pkgname-static"
+source="https://github.com/containers/crun/releases/download/$pkgver/crun-$pkgver.tar.xz"
+
+build() {
+ ./configure --disable-systemd --prefix=/usr
+ make
+}
+
+check() {
+ make tests/tests_libcrun_errors.log
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="170fe5148af06862c02f070c351f18446097e939e19320585078cd9a5e075c6ef06c2e5e64d394b784b9c3f2fae68d72b2a3dcf78041cc8899bb64045dc72cff crun-0.11.tar.xz"