aboutsummaryrefslogtreecommitdiffstats
path: root/testing/csmith/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/csmith/APKBUILD')
-rw-r--r--testing/csmith/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/testing/csmith/APKBUILD b/testing/csmith/APKBUILD
index d1cba970594..b4d368904e9 100644
--- a/testing/csmith/APKBUILD
+++ b/testing/csmith/APKBUILD
@@ -1,29 +1,34 @@
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=csmith
pkgver=2.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Tool for generating random C programs"
url="https://embed.cs.utah.edu/csmith/"
arch="all"
license="BSD-2-Clause"
-depends=""
makedepends="m4"
subpackages="$pkgname-doc"
options="!check" # no test suite
-source="https://embed.cs.utah.edu/csmith/$pkgname-$pkgver.tar.gz
+source="https://embed.cs.utah.edu/csmith/csmith-$pkgver.tar.gz
support-ppc64le.patch
fix-s390x-read_time.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_guess
+ update_config_sub
+}
build() {
- cd "$builddir"
- ./configure --prefix=/usr
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
# scripts depend on source tree to be available