aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cvs-fast-export/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cvs-fast-export/APKBUILD')
-rw-r--r--testing/cvs-fast-export/APKBUILD29
1 files changed, 12 insertions, 17 deletions
diff --git a/testing/cvs-fast-export/APKBUILD b/testing/cvs-fast-export/APKBUILD
index afdcdeda6c3..2ca6f824b1f 100644
--- a/testing/cvs-fast-export/APKBUILD
+++ b/testing/cvs-fast-export/APKBUILD
@@ -1,21 +1,18 @@
# Contributor: TBK <alpine@jjtc.eu>
# Maintainer: TBK <alpine@jjtc.eu>
pkgname=cvs-fast-export
-pkgver=1.55
+pkgver=1.65
pkgrel=0
pkgdesc="Export RCS or CVS history as a fast-import stream"
url="http://www.catb.org/esr/cvs-fast-export/"
arch="all"
license="GPL-2.0-or-later"
depends="cvs rcs"
-makedepends="asciidoc bison flex libxslt"
+makedepends="asciidoctor bison flex libxslt"
checkdepends="python3"
subpackages="$pkgname-doc $pkgname-tools::noarch"
-source="https://gitlab.com/esr/cvs-fast-export/-/archive/$pkgver/cvs-fast-export-$pkgver.tar.gz
- python3.patch
- 01-compile-flags.patch
- disable-test-sporadic.patch
- "
+source="https://gitlab.com/esr/cvs-fast-export/-/archive/$pkgver/cvs-fast-export-$pkgver.tar.gz"
+options="!check" # take 50 years
build() {
# "make all" will run the commands below + html.
@@ -25,7 +22,6 @@ build() {
}
check() {
- tests/setpython python3
# v1.55 - More then one job and the tests
# are executed in the wrong order!
make -j 1 check
@@ -36,15 +32,14 @@ package() {
}
tools() {
- pkgdesc="$pkgdesc (Tools)"
- depends="$pkgname git python3 rsync"
+ pkgdesc="$pkgdesc (extra tools)"
+ depends="$pkgname=$pkgver-r$pkgrel git python3 rsync"
- cd "$pkgdir"/usr/bin
- mkdir -p "$subpkgdir"/usr/bin
- mv cvsconvert cvssync "$subpkgdir"/usr/bin/
+ amove \
+ usr/bin/cvsconvert \
+ usr/bin/cvssync
}
-sha512sums="1765bf4e086232d96b2c4a89d55fdd0028a5cc27630ebe6b34a9bc2f9319ec06802735c039dc516ec78e78af3b634bed4c94233e37d21b0da678de3a63c9ebef cvs-fast-export-1.55.tar.gz
-00ef05acf411154600f31d37795330f39e2951483cc1cba35918b359635f423648038a1f976a4ce78f5209e1b60b4b3b4812ce7348ab426b97df07c45ca638bc python3.patch
-35f738ad85132c54f6f4f521a0a0e21af2124ec71a10c94bf2b2861ca115b693e77df16b0bebb6220e555c3b582d06b2f29d9890e192dbb2d591a9042d2f1f60 01-compile-flags.patch
-687fd54316a0b14935a0421d237ff003985211ef476360395c60cfbf6d8619099c8aa6d3af5ee511b016524f576374e868cc67dcaa5b96367fb7446d669496f4 disable-test-sporadic.patch"
+sha512sums="
+84665f654364c111455edec5c335cf75dbdb8b63759b94eee85b4bc7389d3c90d85e0c84e8d2ba2d7ab89588d568c6e56b6f8c4a8fbd9f3083a370d9b1302e63 cvs-fast-export-1.65.tar.gz
+"