aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cxxopts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cxxopts/APKBUILD')
-rw-r--r--testing/cxxopts/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/testing/cxxopts/APKBUILD b/testing/cxxopts/APKBUILD
deleted file mode 100644
index 20a476e3228..00000000000
--- a/testing/cxxopts/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=cxxopts
-pkgver=3.0.0
-pkgrel=0
-pkgdesc="Lightweight C++ command line option parser as a header only library"
-url="https://github.com/jarro2783/cxxopts"
-arch="noarch"
-license="MIT"
-makedepends="cmake ninja"
-subpackages="$pkgname-dev"
-source="https://github.com/jarro2783/cxxopts/archive/v$pkgver/cxxopts-$pkgver.tar.gz"
-
-build() {
- cmake -G Ninja -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=None \
- -DCXXOPTS_BUILD_TESTS=ON
- cmake --build build
-}
-
-check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-239479a3b35ddef6fc380ac9371e1cf7e3aea066f03e1ea538151fa2fff4296838daa976d55e988d8f87f40c0ae027767bcb214754177499413af1081315565c cxxopts-3.0.0.tar.gz
-"