aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cyclone/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cyclone/APKBUILD')
-rw-r--r--testing/cyclone/APKBUILD54
1 files changed, 0 insertions, 54 deletions
diff --git a/testing/cyclone/APKBUILD b/testing/cyclone/APKBUILD
deleted file mode 100644
index 2a95af840fe..00000000000
--- a/testing/cyclone/APKBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
-pkgname=cyclone
-pkgver=0.33.0
-pkgrel=0
-pkgdesc="A compiler for application development with R7RS Scheme"
-url="https://justinethier.github.io/cyclone/"
-# s390x: ck on s390x does not have ck_pr_cas_8 (used by cyclone)
-# See: https://github.com/concurrencykit/ck/issues/178
-arch="all !s390x"
-license="MIT"
-makedepends="ck-dev cyclone-bootstrap"
-subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/justinethier/cyclone/archive/refs/tags/v$pkgver.tar.gz"
-
-export PREFIX=/usr
-export DATADIR=$PREFIX/lib/cyclone
-
-# Since cyclone itself is written in Scheme it needs to be bootstraped.
-# For this propose, upstream provides a dedicated cyclone-bootstrap
-# repository which includes C files generated by a previous cyclone
-# version. We package cyclone-bootstrap in a separate package and
-# compile the original cyclone Scheme sources using it. This is useful
-# to backport patches from upstream without having to patch
-# compiler-generated C files.
-#
-# It should also be possible to use provides and a recursive dependency
-# for bootstraping in the future. Like we do with rust and others.
-
-build() {
- # Build the cyclone compiler using cyclone-bootstrap.
- PATH="$PATH:/usr/lib/cyclone-bootstrap/bin" make \
- CYC_PTHREAD_SET_STACK_SIZE=1
-}
-
-check() {
- make test
-}
-
-package() {
- DESTDIR="$pkgdir" make install
-}
-
-dev() {
- # Custom dev to not move Cyclone object files.
- # Allows using Cyclone without installing -dev.
- #
- # The -dev subpackage should only be needed for FFI.
- amove /usr/include /usr/lib/libcyclone*
-}
-
-sha512sums="
-7f5d2c9e9499c8909ed6a9d242f0f0755525c57b23e6745b80df2cf2a83e41975fd02349d62321a618b12f45243d94490b6228d158031e859b1edf7df5442bf4 cyclone-0.33.0.tar.gz
-"