aboutsummaryrefslogtreecommitdiffstats
path: root/testing/debconf/fix-makefile_destdir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/debconf/fix-makefile_destdir.patch')
-rw-r--r--testing/debconf/fix-makefile_destdir.patch29
1 files changed, 9 insertions, 20 deletions
diff --git a/testing/debconf/fix-makefile_destdir.patch b/testing/debconf/fix-makefile_destdir.patch
index 7c31b998281..24553f8252e 100644
--- a/testing/debconf/fix-makefile_destdir.patch
+++ b/testing/debconf/fix-makefile_destdir.patch
@@ -5,7 +5,7 @@
MUNGE=xargs perl -i.bak -ne ' \
print $$_."\# This file was preprocessed, do not edit!\n" \
if m:^\#!/usr/bin/perl:; \
-@@ -24,20 +25,24 @@
+@@ -24,60 +25,64 @@
# Anything that goes in the debconf-utils package.
install-utils:
@@ -14,11 +14,11 @@
find . -maxdepth 1 -perm /100 -type f -name 'debconf-*' | grep -v debconf-set-selections | grep -v debconf-show | grep -v debconf-copydb | grep -v debconf-communicate | grep -v debconf-apt-progress | grep -v debconf-escape | \
- xargs -i install {} $(prefix)/usr/bin
+ xargs -i install {} $(DESTDIR)$(PREFIX)/bin
-
++
+# Installs only english man pages
+install-doc:
+ $(MAKE) -C doc PREFIX=$(PREFIX) DESTDIR=$(DESTDIR) install
-+
+
# Anything that goes in the debconf-i18n package.
install-i18n:
- $(MAKE) -C po install
@@ -27,15 +27,6 @@
PERL := perl
PERL_VENDORLIB := $(shell $(PERL) -MConfig -e 'print $$Config{vendorlib}')
- # This would probably be easier if we used setup.py ...
- PYTHON2_SUPPORTED := $(shell pyversions -s)
--PYTHON_SITEDIR = $(prefix)/usr/lib/$(1)/$(if $(filter 2.0 2.1 2.2 2.3 2.4 2.5,$(patsubst python%,%,$(1))),site-packages,dist-packages)
-+PYTHON_SITEDIR = $(DESTDIR)$(PREFIX)/lib/$(1)/$(if $(filter 2.0 2.1 2.2 2.3 2.4 2.5,$(patsubst python%,%,$(1))),site-packages,dist-packages)
-
- # The Python 2 package.
- install-python2:
-@@ -48,47 +53,47 @@
-
# The Python 3 package.
install-python3:
- install -d $(prefix)/usr/lib/python3/dist-packages
@@ -77,10 +68,10 @@
# Other libs and helper stuff.
- install -m 0644 confmodule.sh confmodule $(prefix)/usr/share/debconf/
- install frontend $(prefix)/usr/share/debconf/
-- install -m 0755 transition_db.pl fix_db.pl $(prefix)/usr/share/debconf/
+- install -m 0755 fix_db.pl $(prefix)/usr/share/debconf/
+ install -m 0644 confmodule.sh confmodule $(DESTDIR)$(PREFIX)/share/debconf/
+ install frontend $(DESTDIR)$(PREFIX)/share/debconf/
-+ install -m 0755 transition_db.pl fix_db.pl $(DESTDIR)$(PREFIX)/share/debconf/
++ install -m 0755 fix_db.pl $(DESTDIR)$(PREFIX)/share/debconf/
# Install essential programs.
- install -d $(prefix)/usr/sbin $(prefix)/usr/bin
+ install -d $(DESTDIR)$(PREFIX)/sbin $(DESTDIR)$(PREFIX)/bin
@@ -94,13 +85,11 @@
- find $(prefix)/$(PERL_VENDORLIB)/ $(prefix)/usr/sbin \
- $(prefix)/usr/share/debconf/frontend \
- $(prefix)/usr/share/debconf/*.pl $(prefix)/usr/bin \
-- -name '*.pl' -or -name '*.pm' -or -name 'dpkg-*' -or \
-- -name 'debconf-*' -or -name 'frontend' | \
-+ find $(DESTDIR)/$(PERL_VENDORLIB)/ $(DESTDIR)$(PREFIX)/sbin \
-+ $(DESTDIR)$(PREFIX)/share/debconf/frontend \
++ find $(DESTDIR)/$(PERL_VENDORLIB)/ $(DESTDIR)$(PREFIX)/sbin \
++ $(DESTDIR)$(PREFIX)/share/debconf/frontend \
+ $(DESTDIR)$(PREFIX)/share/debconf/*.pl $(DESTDIR)$(PREFIX)/bin \
-+ -name '*.pl' -or -name '*.pm' -or -name 'dpkg-*' -or \
-+ -name 'debconf-*' -or -name 'frontend' | \
+ -name '*.pl' -or -name '*.pm' -or -name 'dpkg-*' -or \
+ -name 'debconf-*' -or -name 'frontend' | \
grep -v Client/ConfModule | $(MUNGE)
- find $(prefix) -name '*.bak' | xargs rm -f
+ find $(DESTDIR) -name '*.bak' | xargs rm -f