aboutsummaryrefslogtreecommitdiffstats
path: root/testing/delta/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/delta/APKBUILD')
-rw-r--r--testing/delta/APKBUILD25
1 files changed, 0 insertions, 25 deletions
diff --git a/testing/delta/APKBUILD b/testing/delta/APKBUILD
deleted file mode 100644
index 4faa24309b4..00000000000
--- a/testing/delta/APKBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# Contributor: Aleks Bunin <alpinelinux@compuix.com>
-# Maintainer: Aleks Bunin <alpinelinux@compuix.com>
-pkgname=delta
-pkgver=0.9.1
-pkgrel=0
-pkgdesc="A viewer for git and diff output"
-url="https://github.com/dandavison/delta"
-arch="all !s390x !mips !mips64 !riscv64" # Limited by cargo
-license="MIT"
-makedepends="cargo"
-source="$pkgname-$pkgver.tar.gz::https://github.com/dandavison/delta/archive/$pkgver.tar.gz"
-
-build() {
- cargo build --release --locked
-}
-
-check() {
- cargo test --release --locked
-}
-
-package() {
- install -Dm755 target/release/"$pkgname" "$pkgdir"/usr/bin/"$pkgname"
-}
-
-sha512sums="e667a08a7d2ea8db8033cb7c9c19b7c0536894557089ee5e9f811cb264154798840085b1151f3410772f7e00b35f0ac2508cb4f82f8d78cf0ed395b0c0beda7a delta-0.9.1.tar.gz"