summaryrefslogtreecommitdiffstats
path: root/testing/devhelp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/devhelp/APKBUILD')
-rw-r--r--testing/devhelp/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/devhelp/APKBUILD b/testing/devhelp/APKBUILD
new file mode 100644
index 00000000000..7e0f68fda08
--- /dev/null
+++ b/testing/devhelp/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=devhelp
+pkgver=3.32.0
+pkgrel=0
+pkgdesc="API documentation browser for GTK+ and GNOME"
+url="https://wiki.gnome.org/Apps/Devhelp"
+arch="all"
+license="GPL-2.0-or-later"
+depends="gsettings-desktop-schemas"
+makedepends="meson gobject-introspection-dev gsettings-desktop-schemas-dev
+ webkit2gtk-dev amtk-dev glib-dev itstool"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/devhelp/${pkgver%.*}/devhelp-${pkgver}.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="c70e526ee4ed480c2c5be9cd1b93630cc5168cfef4922b7d89184e9ade78d42910a24f6d2d0f0f55059005de71f83f30f912b43c9f2ca6a3520541bb50059c41 devhelp-3.32.0.tar.xz"