aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dolphin-plugins/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/dolphin-plugins/APKBUILD')
-rw-r--r--testing/dolphin-plugins/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/testing/dolphin-plugins/APKBUILD b/testing/dolphin-plugins/APKBUILD
index a07d03fb315..fd72b05e42b 100644
--- a/testing/dolphin-plugins/APKBUILD
+++ b/testing/dolphin-plugins/APKBUILD
@@ -1,30 +1,31 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=dolphin-plugins
-pkgver=19.12.2
-pkgrel=1
+pkgver=19.12.3
+pkgrel=0
arch="all !armhf"
url="https://www.kde.org/applications/system/dolphin/"
pkgdesc="Extra Dolphin plugins"
license="GPL-2.0-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev kxmlgui-dev ki18n-dev kio-dev ktextwidgets-dev ktexteditor-dev dolphin-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-plugins-$pkgver.tar.xz"
subpackages="$pkgname-lang"
build() {
- cmake \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
+ make -C build
}
check() {
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" make -C build install
}
-sha512sums="f825b61c0825156d6f0abfefa1ce617135a4bf9521d7feca2a3b677bbcb386d098ceb1c57ca29847e5bfd0e659bf6a2efce3e9a6676e60576f5f58968375ab1a dolphin-plugins-19.12.2.tar.xz"
+sha512sums="f6d1ce129095d0ae608b2da4d91f55b93bb8fe94795c09217cc87607bb50cd8dcc5a7dac21b8655f9993da56ef90fa705520c7ac928295edb5254050af9c4a1e dolphin-plugins-19.12.3.tar.xz"