aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dotnet5-stage0/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/dotnet5-stage0/APKBUILD')
-rw-r--r--testing/dotnet5-stage0/APKBUILD195
1 files changed, 0 insertions, 195 deletions
diff --git a/testing/dotnet5-stage0/APKBUILD b/testing/dotnet5-stage0/APKBUILD
deleted file mode 100644
index 1e4465641b6..00000000000
--- a/testing/dotnet5-stage0/APKBUILD
+++ /dev/null
@@ -1,195 +0,0 @@
-# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
-# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
-
-# Variables for dotnet-stage0 build version 5.0
-# This APKBUILD is designed to be the same for version 5.0 and under
-# except for the variables in this first section
-
-pkgname=dotnet5-stage0
-pkgver=5.0.211
-pkgrel=0
-_artifactsver=5.0.208
-_source_artifactsver=0.1.0-$_artifactsver-1454404-20211104.5
-_source_referencesver=1.0.0-beta.21566.2
-_nappo_get=''
-_nappo_exclude='*Intermediate*'
-
-# Following for dotnet-stage0 build version 5.0 and below
-_pkgver_macro=${pkgver%.*}
-_pkgver_prior=1
-_pkgver_name=${_pkgver_macro//[.0]}
-pkgdesc="The .NET $_pkgver_macro SDK, Microsoft build for use by dotnet$_pkgver_name aport"
-arch="x86_64"
-url=https://www.microsoft.com/net/core
-license="MIT"
-makedepends="
- krb5-libs
- libcurl
- libintl
- lttng-ust
- py3-packaging
- unzip
- zlib
- "
-subpackages="dotnet$_pkgver_name-stage0-artifacts"
-options="!check" # No test suite
-_default_source="
- https://dotnetcli.azureedge.net/source-built-artifacts/assets/Private.SourceBuilt.Artifacts.$_source_artifactsver.tar.gz
- https://dotnetfeed.blob.core.windows.net/dotnet-core/assets/Private.SourceBuild.ReferencePackages.$_source_referencesver.tar.gz
- https://gist.githubusercontent.com/omajid/c04b6025de49d0b7b18ab4a7e789484e/raw/b33c57f6bf9c00bb8633375123d2d3594fe81c26/nappo.py
- "
-builddir="$srcdir"
-
-# custom function that converts Alpine arch syntax to dotnet arch syntax
-_get_arch() {
- case $1 in
- x86_64) local arch=x64;;
- aarch64) local arch=arm64;;
- armv7) local arch=arm;;
- esac
- echo $arch
-}
-_dotnet_arch=$(_get_arch $CARCH)
-
-# custom source updater function for all dotnet versions
-#
-# Prebuilt artifacts only provides linux-x64 nukgs. As Alpine uses linux-musl,
-# the below scripts updates source to fetch the musl version of those packages,
-# allowing packaging of the correct architecture. Thus, everytime Artifacts
-# is updated, or new architectures are added, this function needs to be
-# executed using 'abuild _update_source'
-_update_source() {
- [ -z "$source" ] \
- && msg "Removing source from APKBUILD"
- sed -E -i \
- -e '/^source=".*"$/d' \
- -e '/^source="/,/"$/d' \
- \
- -e "/^source='.*'\$/d" \
- -e "/^source='/,/'\$/d" \
- APKBUILD
-
- source="$_default_source"
- fetch
- local nuget_source="$_default_source"
- msg "Updating source"
- local nappo_exclude="$_nappo_exclude"
- # shellcheck disable=3045
- local nappo_exclude="$(printf '--exclude %s ' $nappo_exclude)"
- local nappo_get=$(tar --list -f "$srcdir"/Private.SourceBuilt.Artifacts.*.tar.gz --wildcards '*.linux-x64.*' $nappo_exclude)
- local nappo_get="$_nappo_get $nappo_get"
- for package in $nappo_get; do
- for _arch in $arch; do
- local filename=${package##*/} # Extracts just filename
- local suffix=${filename##*[0-9]} # Extracts what's after version number
- local nupkg=${filename/$suffix} # Extracts nupkg name with version
- [ -z "${filename##*servicing*}" ] && local nupkg=${filename%%-servicing*}
- local name=${nupkg%*.*.*.*} # Extracts name without version
- local version=${nupkg/$name.} # Extracts version out of nupkg using name
- local name=${name/linux-x64/linux-musl-$(_get_arch $_arch)} # Converts to current arch
- [ -z "${filename##*servicing*}" ] && unset version
- echo "Getting $name [${version:-latest}] (replaces $package)"
- local nappo_out="$(python3 "$srcdir"/nappo.py download --verbose $name ${version:-})"
- local nupkg="${nappo_out#*.nupkg}"
- local uri=${nappo_out/$nupkg}
- local nupkg=$(echo $nupkg | tr -d '\n')
- [ -f "$nupkg" ] && mv $nupkg "$SRCDEST"/.
- local nuget_source="$nuget_source $uri"
- [ -z "${name##*linux*}" ] || break
- done
- done
- for _arch in $arch; do
- local nuget_source="$nuget_source https://dotnetcli.azureedge.net/dotnet/Sdk/$pkgver/dotnet-sdk-$pkgver-linux-musl-$(_get_arch $_arch).tar.gz"
- done
- local nuget_source="$(printf '%s\n' $nuget_source)"
- printf 'source="\n%s\n"\n' "$nuget_source" >>"$APKBUILD"
-}
-
-unpack() {
- verify
- initdcheck
- mkdir -p "$srcdir"
- msg "Unpacking Private.SourceBuilt.Artifacts"
- gunzip Private.SourceBuilt.Artifacts.*.tar.gz
- msg "Unpacking Private.SourceBuild.Reference.Packages"
- gunzip Private.SourceBuild.Reference*.tar.gz
-}
-
-package() {
- # directory creation
- install -dm 755 "$pkgdir"/usr/share/dotnet/bootstrap/$pkgver
-
- # unpack prebuilt sdk / runtimes
- tar -xzf "$srcdir"/dotnet-sdk-$_pkgver_macro*$_dotnet_arch.tar.gz -C "$pkgdir"/usr/share/dotnet/bootstrap/$pkgver --no-same-owner
-}
-
-artifacts() {
- pkgdesc="Internal package for building .NET $_pkgver_macro Software Development Kit, Microsoft build for use by dotnet$_pkgver_name aport"
-
- # directory creation
- install -dm 755 \
- "$subpkgdir"/usr/share/dotnet/artifacts/$pkgver/SourceBuildReferencePackages \
- "$subpkgdir"/usr/share/licenses
-
- # extracts artifact without Intermediate and binary packages
- tar -xf "$srcdir"/Private.SourceBuilt.Artifacts.*.tar -C "$subpkgdir"/usr/share/dotnet/artifacts/$pkgver/ --no-same-owner\
- --exclude '*x64*' \
- --exclude '*Intermediate*'
-
- # replace loose x64 bits with arch bits
- for i in "$subpkgdir"/usr/share/dotnet/artifacts/"$pkgver"/coreclr-tools/*; do
- case $i in
- *.md) continue ;;
- *ilasm) unzip -ojqXK "$srcdir"/runtime.linux-musl-$_dotnet_arch.microsoft.netcore.ilasm.*.nupkg runtimes/linux-musl-$_dotnet_arch/native/ilasm -d "$subpkgdir"/usr/share/dotnet/artifacts/$pkgver/coreclr-tools/. ;;
- *ildasm) unzip -ojqXK "$srcdir"/runtime.linux-musl-$_dotnet_arch.microsoft.netcore.ildasm.*.nupkg runtimes/linux-musl-$_dotnet_arch/native/ildasm -d "$subpkgdir"/usr/share/dotnet/artifacts/$pkgver/coreclr-tools/. ;;
- *) unzip -ojqXK "$srcdir"/runtime.linux-musl-$_dotnet_arch.microsoft.netcore.app.*.nupkg runtimes/linux-musl-$_dotnet_arch/native/${i##*/} -d "$subpkgdir"/usr/share/dotnet/artifacts/$pkgver/coreclr-tools/. ;;
- esac
- chmod 755 "$i"
- done
-
- # place proper binary packages
- for i in "$srcdir"/*.nupkg; do
- case $i in
- *linux*) install -m 644 "$srcdir"/*$_dotnet_arch*.nupkg "$subpkgdir"/usr/share/dotnet/artifacts/$pkgver/. ;;
- *) install -m 644 "$srcdir"/*.nupkg "$subpkgdir"/usr/share/dotnet/artifacts/$pkgver/. ;;
- esac
- done
-
- # extract reference packages, a couple of packages need to be excludes due to
- # causing conflict with non-reference packages
- tar -xf "$srcdir"/Private.SourceBuild.Reference*.tar -C "$subpkgdir"/usr/share/dotnet/artifacts/$pkgver/SourceBuildReferencePackages/ --no-same-owner
-}
-source="
-https://dotnetcli.azureedge.net/source-built-artifacts/assets/Private.SourceBuilt.Artifacts.0.1.0-5.0.208-1454404-20211104.5.tar.gz
-https://dotnetfeed.blob.core.windows.net/dotnet-core/assets/Private.SourceBuild.ReferencePackages.1.0.0-beta.21566.2.tar.gz
-https://gist.githubusercontent.com/omajid/c04b6025de49d0b7b18ab4a7e789484e/raw/b33c57f6bf9c00bb8633375123d2d3594fe81c26/nappo.py
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/45bacae2-5efb-47c8-91e5-8ec20c22b4f8/nuget/v3/flat2//Microsoft.AspNetCore.App.Runtime.linux-musl-x64/5.0.11/microsoft.aspnetcore.app.runtime.linux-musl-x64.5.0.11.nupkg
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/45bacae2-5efb-47c8-91e5-8ec20c22b4f8/nuget/v3/flat2//Microsoft.NETCore.App.Host.linux-musl-x64/5.0.11/microsoft.netcore.app.host.linux-musl-x64.5.0.11.nupkg
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/45bacae2-5efb-47c8-91e5-8ec20c22b4f8/nuget/v3/flat2//Microsoft.NETCore.App.Runtime.linux-musl-x64/5.0.11/microsoft.netcore.app.runtime.linux-musl-x64.5.0.11.nupkg
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/45bacae2-5efb-47c8-91e5-8ec20c22b4f8/nuget/v3/flat2//runtime.linux-musl-x64.Microsoft.NETCore.App/2.2.0-preview2-26905-02/runtime.linux-musl-x64.microsoft.netcore.app.2.2.0-preview2-26905-02.nupkg
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/45bacae2-5efb-47c8-91e5-8ec20c22b4f8/nuget/v3/flat2//runtime.linux-musl-x64.Microsoft.NETCore.DotNetAppHost/5.0.11/runtime.linux-musl-x64.microsoft.netcore.dotnetapphost.5.0.11.nupkg
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/45bacae2-5efb-47c8-91e5-8ec20c22b4f8/nuget/v3/flat2//runtime.linux-musl-x64.Microsoft.NETCore.DotNetHost/5.0.11/runtime.linux-musl-x64.microsoft.netcore.dotnethost.5.0.11.nupkg
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/45bacae2-5efb-47c8-91e5-8ec20c22b4f8/nuget/v3/flat2//runtime.linux-musl-x64.Microsoft.NETCore.DotNetHostPolicy/5.0.11/runtime.linux-musl-x64.microsoft.netcore.dotnethostpolicy.5.0.11.nupkg
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/45bacae2-5efb-47c8-91e5-8ec20c22b4f8/nuget/v3/flat2//runtime.linux-musl-x64.Microsoft.NETCore.DotNetHostResolver/5.0.11/runtime.linux-musl-x64.microsoft.netcore.dotnethostresolver.5.0.11.nupkg
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/a8a526e9-91b3-4569-ba2d-ff08dbb7c110/nuget/v3/flat2//runtime.linux-musl-x64.Microsoft.NETCore.ILAsm/5.0.0-alpha1.19459.9/runtime.linux-musl-x64.microsoft.netcore.ilasm.5.0.0-alpha1.19459.9.nupkg
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/a8a526e9-91b3-4569-ba2d-ff08dbb7c110/nuget/v3/flat2//runtime.linux-musl-x64.Microsoft.NETCore.ILDAsm/5.0.0-alpha1.19459.9/runtime.linux-musl-x64.microsoft.netcore.ildasm.5.0.0-alpha1.19459.9.nupkg
-https://pkgs.dev.azure.com/dnceng/9ee6d478-d288-47f7-aacc-f6e6d082ae6d/_packaging/a8a526e9-91b3-4569-ba2d-ff08dbb7c110/nuget/v3/flat2//runtime.linux-musl-x64.Microsoft.NETCore.TestHost/5.0.0-alpha1.19459.9/runtime.linux-musl-x64.microsoft.netcore.testhost.5.0.0-alpha1.19459.9.nupkg
-https://dotnetcli.azureedge.net/dotnet/Sdk/5.0.211/dotnet-sdk-5.0.211-linux-musl-x64.tar.gz
-"
-sha512sums="
-9b63922552a6f8463e5eb6df70a1c85f44caa9c8156ce20c4cff7deffea0a76c732954629097692ff32272d4fcd59410759f25a273175fd86135e9f2a4cea58f Private.SourceBuilt.Artifacts.0.1.0-5.0.208-1454404-20211104.5.tar.gz
-af2ae9d9cb9e06621ecf150eb950b53f830b8586b6da0474ed39735f2136bf474154d673d7f7c44d23bf4d29e62ab4709acf0bec7575b28fc7087a56cb2eb7cc Private.SourceBuild.ReferencePackages.1.0.0-beta.21566.2.tar.gz
-90b3ec14fd02cbef8af2086c26ef2f4f23c4c5ce83dac39cacbb36e506ea9914aae6c3b3580af2e71141b8f0435b4910f60970333011b4ddd594839f5fd7ec8e nappo.py
-77e951f1992152ba5515b2073aaf915c99574186b0a4957cc0523da211f54fe387065f0011a491805c7c20cae80b30929f285eebf8904fd02cddf762092f8a0e microsoft.aspnetcore.app.runtime.linux-musl-x64.5.0.11.nupkg
-ddf83ff84711be8fc1652c59cddf23fe97442c6b404c0932c60baac01c6c044a8f8a481396e28414c9b58b6d3bb38e083c4c743d04176bb2957787b61c429531 microsoft.netcore.app.host.linux-musl-x64.5.0.11.nupkg
-b651d6a8e5595eaa946a09a4ac0eb38844de6ba53b4a461ad0a1ea501bc7fdf96a36bc071da05d45d291a707a3470aae233373b6f6346ee255b861e009ebf9dc microsoft.netcore.app.runtime.linux-musl-x64.5.0.11.nupkg
-ec01c7482f040c06726ca7bf67fd9c83e83b6af4f46ccd16f7892c1034ae408c0d9220e24952060316e19df38f15f86b8d5ae8f1f52d3e38d658b4e94304d42b runtime.linux-musl-x64.microsoft.netcore.app.2.2.0-preview2-26905-02.nupkg
-c33efa123adfa36192643c40b5c35972f376d59ab67a4b201eecce7efafd61e46918e5a0f966b30dd3ba4e481becd1db8965a4ca723c0db212b90541d6e72037 runtime.linux-musl-x64.microsoft.netcore.dotnetapphost.5.0.11.nupkg
-4ebf38a8249e96dd6c05430c380d217c22ca409458c0d08b90bf36f49870e03b5e9e0e6130389cda5c9aed98604185a8d46bd3cc4921083776556e811924b79b runtime.linux-musl-x64.microsoft.netcore.dotnethost.5.0.11.nupkg
-47affec93733372fa09436bfb185999d0e2296fa7ecf6434b3e7e7e007282dcbcb4e8c49a39a7962570b4c036f70aaeba02a68a31b13d54914392b3791b3d99c runtime.linux-musl-x64.microsoft.netcore.dotnethostpolicy.5.0.11.nupkg
-51bdd91f8ed27e998f144c983a910421d46d563c6ec6a20aa81aef4e07842509b513a083adada22e9205cb481cbbb3999bb86ae0ffdd39412bf5a9b45981461a runtime.linux-musl-x64.microsoft.netcore.dotnethostresolver.5.0.11.nupkg
-b5c03376ed2e56955463a4c8328ec8682d11fca5085c091025df989b1add13ef5510d5079c1c541238610180d5871ad0a7ec2b4a617d40ca4fdbdf85500769b2 runtime.linux-musl-x64.microsoft.netcore.ilasm.5.0.0-alpha1.19459.9.nupkg
-44609e872e0aa76c682ffa34951cbdbe2e590686342263e71b8ec012ef3e5d242f17ab23576679dc27d451b3a5a59f1a1bf9abd8a620e777e8552486d366058c runtime.linux-musl-x64.microsoft.netcore.ildasm.5.0.0-alpha1.19459.9.nupkg
-7d9f6f15fa66ee512989d63ccfb996171f046aa6c853d4856284ec696042676ffee24027595fa358ea8c01083370548f2a1f8b42a422a86b99c10d31114dc9f1 runtime.linux-musl-x64.microsoft.netcore.testhost.5.0.0-alpha1.19459.9.nupkg
-fa11ced281b85bf38ea63462f7296a8acd198a19979551c4966044a6e7380d42b183856f4492952af0a1b47426a8c35ade91cf87e3ce2a8ba848a12c0bc26812 dotnet-sdk-5.0.211-linux-musl-x64.tar.gz
-"