aboutsummaryrefslogtreecommitdiffstats
path: root/testing/electrs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/electrs/APKBUILD')
-rw-r--r--testing/electrs/APKBUILD26
1 files changed, 0 insertions, 26 deletions
diff --git a/testing/electrs/APKBUILD b/testing/electrs/APKBUILD
deleted file mode 100644
index 4a199a6493a..00000000000
--- a/testing/electrs/APKBUILD
+++ /dev/null
@@ -1,26 +0,0 @@
-# Maintainer: MichaƂ Adamski <michal@ert.pl>
-pkgname=electrs
-pkgver=0.9.4
-pkgrel=0
-pkgdesc="Efficient re-implementation of Electrum Server in Rust"
-url="https://github.com/romanz/electrs"
-license="MIT"
-arch="x86 x86_64 aarch64" # limited by rust/cargo and rocksdb
-makedepends="cargo rocksdb-dev<6.24 clang-libs"
-source="https://github.com/romanz/electrs/archive/v$pkgver/electrs-$pkgver.tar.gz"
-
-build() {
- ROCKSDB_INCLUDE_DIR=/usr/include ROCKSDB_LIB_DIR=/usr/lib cargo build --all --features "metrics_process" --release --locked
-}
-
-check() {
- cargo test --all --release --locked
-}
-
-package() {
- install -Dm755 target/release/$pkgname -t "$pkgdir"/usr/bin
-}
-
-sha512sums="
-7245472534ba6c59858c73e8c7f37118e02ae03698c83325f9e9a6c17d94b0614e9810151f25509288ab7a65e6910fbf9b22afeb9eb9c92e9dc46c31bd79fe25 electrs-0.9.4.tar.gz
-"