aboutsummaryrefslogtreecommitdiffstats
path: root/testing/elfio/fix-cmake-install-dir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/elfio/fix-cmake-install-dir.patch')
-rw-r--r--testing/elfio/fix-cmake-install-dir.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/elfio/fix-cmake-install-dir.patch b/testing/elfio/fix-cmake-install-dir.patch
new file mode 100644
index 00000000000..22965925efa
--- /dev/null
+++ b/testing/elfio/fix-cmake-install-dir.patch
@@ -0,0 +1,35 @@
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Sat, 11 Dec 2021 12:00:39 +0100
+Subject: [PATCH] Fix install directory for cmake files
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 87de541..8e4fe8a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -78,7 +78,7 @@ if(IS_TOP_PROJECT)
+ "${PROJECT_SOURCE_DIR}/cmake/${PROJECT_NAME}Config.cmake.in"
+ "${PROJECT_BINARY_DIR}/${PROJECT_NAME}Config.cmake"
+ INSTALL_DESTINATION
+- ${CMAKE_INSTALL_DATAROOTDIR}/${PROJECT_NAME}/cmake)
++ ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}/)
+
+ # Install the previously generated "config" and "version" files
+ install(
+@@ -86,7 +86,7 @@ if(IS_TOP_PROJECT)
+ "${PROJECT_BINARY_DIR}/${PROJECT_NAME}Config.cmake"
+ "${PROJECT_BINARY_DIR}/${PROJECT_NAME}ConfigVersion.cmake"
+ DESTINATION
+- ${CMAKE_INSTALL_DATAROOTDIR}/${PROJECT_NAME}/cmake)
++ ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}/)
+
+ # Install the entire local `elfio` directory to the include directory
+ install(
+@@ -107,7 +107,7 @@ if(IS_TOP_PROJECT)
+ NAMESPACE
+ ${PROJECT_NAME}::
+ DESTINATION
+- ${CMAKE_INSTALL_DATAROOTDIR}/${PROJECT_NAME}/cmake)
++ ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}/)
+
+ # Add the elfio target to the ${PROJECT_NAME}_Targets export
+ install(