aboutsummaryrefslogtreecommitdiffstats
path: root/testing/envconsul/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/envconsul/APKBUILD')
-rw-r--r--testing/envconsul/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/testing/envconsul/APKBUILD b/testing/envconsul/APKBUILD
index cec67d803b1..e6f9dc6e6a7 100644
--- a/testing/envconsul/APKBUILD
+++ b/testing/envconsul/APKBUILD
@@ -1,17 +1,21 @@
# Contributor: Gennady Feldman <gena01@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=envconsul
-pkgver=0.12.0
-pkgrel=0
+pkgver=0.13.2
+pkgrel=5
pkgdesc="Read and set environmental variables for processes from Consul."
url="https://www.consul.io/"
license="MPL-2.0"
arch="all"
makedepends="go"
+options="net chmod-clean"
source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/envconsul/archive/v$pkgver.tar.gz"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
- export CGO_ENABLED="0"
mkdir -p pkg/linux-$CARCH
go build -v -o pkg/linux-$CARCH/$pkgname
}
@@ -26,5 +30,5 @@ package() {
}
sha512sums="
-8bf9eb5a04272d634276d3b1f1d29e15b768a074b10af6d31cdd436d071da05f8298935945f8df02204857d8e340df0e43b1cef5ccafe3165ac1fe697391521e envconsul-0.12.0.tar.gz
+dacc65e19553de897195397126664882e3dedd4b9929c83c519311010ff1ab62663425556261a2ce3f37035576b63b4f26c4a0219dfd663d05e852c4cee2e6bb envconsul-0.13.2.tar.gz
"