aboutsummaryrefslogtreecommitdiffstats
path: root/testing/esptool/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/esptool/APKBUILD')
-rw-r--r--testing/esptool/APKBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/testing/esptool/APKBUILD b/testing/esptool/APKBUILD
index dd254ea766b..df6f1ba1de8 100644
--- a/testing/esptool/APKBUILD
+++ b/testing/esptool/APKBUILD
@@ -2,37 +2,42 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=esptool
-pkgver=4.1
-pkgrel=0
+pkgver=4.7.0
+pkgrel=1
pkgdesc="ESP8266 and ESP32 serial bootloader utility"
url="https://docs.espressif.com/projects/esptool"
license="GPL-2.0-or-later"
arch="noarch"
-depends="python3 py3-cryptography py3-ecdsa py3-pyserial py3-bitstring py3-reedsolo"
-makedepends="py3-build py3-installer py3-setuptools py3-wheel"
-checkdepends="py3-elftools"
+depends="
+ py3-bitstring
+ py3-cryptography
+ py3-ecdsa
+ py3-intelhex
+ py3-pyserial
+ py3-reedsolo
+ py3-yaml
+ "
+makedepends="py3-gpep517 py3-installer py3-setuptools py3-wheel"
+checkdepends="py3-elftools py3-pkcs11 py3-pytest py3-requests"
+subpackages="$pkgname-pyc"
source="https://github.com/espressif/esptool/archive/v$pkgver/esptool-$pkgver.tar.gz"
build() {
- python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m installer -d testenv \
- dist/esptool-$pkgver-py3-none-any.whl
-
- local sitedir="$(python3 -c 'import site;print(site.getsitepackages()[0])')"
-
- for test in imagegen espsecure merge_bin modules; do
- PYTHONPATH="$PWD/testenv/$sitedir" python3 test/test_$test.py
- done
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -m host_test
}
package() {
- python3 -m installer -d "$pkgdir" \
- dist/esptool-$pkgver-py3-none-any.whl
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-b9df8d361fe1a97f0649fed03abc919df1c2ff118dc4dd05abeec641ba2d16e6c308894bd91657768e03a6801ec9e5393e573b4c3016b624e842fef7c6354b41 esptool-4.1.tar.gz
+dda2af5d9b2f8a4ec5706eaf58021e95094c152380c732074809c370a5d1bfaeb424cb27f69a3b980dec83ae9c4c9ee1eddfeb0a7990c3b1f1494160a2d369cc esptool-4.7.0.tar.gz
"