aboutsummaryrefslogtreecommitdiffstats
path: root/testing/esptool/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/esptool/APKBUILD')
-rw-r--r--testing/esptool/APKBUILD49
1 files changed, 30 insertions, 19 deletions
diff --git a/testing/esptool/APKBUILD b/testing/esptool/APKBUILD
index 4f4d4baf52e..df6f1ba1de8 100644
--- a/testing/esptool/APKBUILD
+++ b/testing/esptool/APKBUILD
@@ -1,32 +1,43 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer:
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
pkgname=esptool
-pkgver=3.2
-pkgrel=0
+pkgver=4.7.0
+pkgrel=1
pkgdesc="ESP8266 and ESP32 serial bootloader utility"
-options="!check" # tests require older version of pycodestyle
-url="https://github.com/espressif/esptool"
-arch="noarch"
+url="https://docs.espressif.com/projects/esptool"
license="GPL-2.0-or-later"
-depends="python3 py3-pyserial py3-ecdsa py3-pyaes"
-makedepends="py3-setuptools"
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/espressif/esptool/archive/v$pkgver.tar.gz
- remove-py-wheel-requirement.patch"
+arch="noarch"
+depends="
+ py3-bitstring
+ py3-cryptography
+ py3-ecdsa
+ py3-intelhex
+ py3-pyserial
+ py3-reedsolo
+ py3-yaml
+ "
+makedepends="py3-gpep517 py3-installer py3-setuptools py3-wheel"
+checkdepends="py3-elftools py3-pkcs11 py3-pytest py3-requests"
+subpackages="$pkgname-pyc"
+source="https://github.com/espressif/esptool/archive/v$pkgver/esptool-$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -m host_test
+}
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
- install -m644 CONTRIBUTING.md README.md \
- "$pkgdir"/usr/share/doc/$pkgname/
+package() {
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-5e67b3a17190e051d7706ee2dbbe855488765a7bfed15b15f5a04022c3fbf19112905ba6a672c37b1bac5501d45d477cfff07c004cd83b2d1a111430992cefc1 esptool-3.2.tar.gz
-3474afb4b455c93d705334ea81450b21f2ff29858d266a9a4c157857cc7cc35ef7e8fe36758b64679f93d02b3d6647c32b36926051f2b8afa7dfeb0de82b3c4a remove-py-wheel-requirement.patch
+dda2af5d9b2f8a4ec5706eaf58021e95094c152380c732074809c370a5d1bfaeb424cb27f69a3b980dec83ae9c4c9ee1eddfeb0a7990c3b1f1494160a2d369cc esptool-4.7.0.tar.gz
"