aboutsummaryrefslogtreecommitdiffstats
path: root/testing/etcd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/etcd/APKBUILD')
-rw-r--r--testing/etcd/APKBUILD37
1 files changed, 14 insertions, 23 deletions
diff --git a/testing/etcd/APKBUILD b/testing/etcd/APKBUILD
index f1056ec0f8c..8ab11d8d7ea 100644
--- a/testing/etcd/APKBUILD
+++ b/testing/etcd/APKBUILD
@@ -1,17 +1,17 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=etcd
-pkgver=3.5.1
-pkgrel=0
+pkgver=3.5.13
+pkgrel=1
pkgdesc="A highly-available key value store for shared configuration and service discovery"
-options="chmod-clean"
url="https://github.com/etcd-io/etcd"
license="Apache-2.0"
arch="all"
makedepends="go bash"
install="$pkgname.pre-install"
provides="etcd-api"
-provider_priority=1
+provider_priority=2
+options="net chmod-clean"
pkgusers="etcd"
pkggroups="etcd"
subpackages="$pkgname-doc $pkgname-ctl $pkgname-openrc"
@@ -21,19 +21,14 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/coreos/etcd/archive/v$pkgver
$pkgname.initd
"
-export CGO_ENABLED=0
-
-prepare() {
- default_prepare
- export GOPATH="$(pwd)/_gopath"
- export GOFLAGS="$GOFLAGS -mod=mod"
- _coreos="$GOPATH/src/github.com/etcd-io"
- mkdir -vp $_coreos
- ln -vsf $srcdir/$pkgname-$pkgver $_coreos/$pkgname
-}
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+export GOFLAGS="$GOFLAGS -mod=mod"
+export CGO_ENABLED=1
build() {
- GO_LDFLAGS="-w -s" bash -x ./build
+ bash -x ./build.sh
}
package() {
@@ -41,25 +36,21 @@ package() {
chown -R $pkgusers:$pkggroups "$pkgdir"/var/lib/$pkgname
chmod 700 "$pkgdir"/var/lib/$pkgname
install -Dm755 bin/etcd "$pkgdir"/usr/bin/etcd
+ install -Dm755 bin/etcdctl "$pkgdir"/usr/bin/etcdctl
install -Dm644 $srcdir/$pkgname.yaml-$pkgver "$pkgdir"/etc/etcd/conf.yml
install -Dm644 $srcdir/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
install -Dm755 $srcdir/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-cleanup_srcdir() {
- go clean -modcache
- default_cleanup_srcdir
-}
-
ctl() {
pkgdesc="A command-line client for etcd"
- install -Dm755 "$builddir"/bin/etcdctl "$subpkgdir"/usr/bin/etcdctl
+ amove usr/bin/etcdctl
}
sha512sums="
-4cf6f3f422c8390287d5eca7518e1e6ab078fca2d1e5708636886cf57dc2901d56f5b5b713d814e16ebe349bc3abe59e0ea021bb33d8038f97d69bd1e76f8e73 etcd-3.5.1.tar.gz
-86f726d77a3fbe87908c5a5b6e3c5b81f0b428de05a211fd1ea82058285c1a64898ca8a79ef8458db5ed5fd53d72e3a457eb55c0c297981363edf60d2d28b4af etcd.yaml-3.5.1
+dc85d80079b61e96eb06eb573d41d8972060392e49140a2414c283ea9edfef7b01d5554e50c7ab37c6ad079b373ae12a1b84dbcc533addc1d4d30a2a5abf7b7b etcd-3.5.13.tar.gz
+92e6a22dfe12eef76c186c04a4aadca5318300c18aefc979cc03926fddf40e0e9b3bf2b40b75702f2f710dc65420da676c734cfe4d246d86e0728d6e99f43426 etcd.yaml-3.5.13
8b917d2b3a136a97dd9565a91377420ce1f812bfb10bb0caa95f1024dd366cb78ebb0539f16ddfbc399325d41a6664b856d49c5c9aa67bc27e36040f2227356e etcd.confd
b67f7fd209a29ed2a6ef86d5a3c07cf5dc4138af7c61c3a928471cd79f5579ce7861fd21167db332727dfb2a8e554722366c6505e447f3b2feeae819f869aa11 etcd.initd
"