aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ffmpegthumbs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ffmpegthumbs/APKBUILD')
-rw-r--r--testing/ffmpegthumbs/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/ffmpegthumbs/APKBUILD b/testing/ffmpegthumbs/APKBUILD
new file mode 100644
index 00000000000..ebc2b4989ac
--- /dev/null
+++ b/testing/ffmpegthumbs/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=ffmpegthumbs
+pkgver=19.04.2
+pkgrel=0
+arch="all"
+url="https://www.kde.org/applications/multimedia/"
+pkgdesc="FFmpeg-based thumbnail creator for video files"
+license="GPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kio-dev ki18n-dev kconfig-dev ffmpeg-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="6d07d8dac339d0f3274c85b205feac998ccfaa57b6fee816bdf75c631b6e321c22d9af7e057faeb7f721def09ddb2da239bc81c22582772a9d7d3e8720de24dd ffmpegthumbs-19.04.2.tar.xz"