aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fheroes2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/fheroes2/APKBUILD')
-rw-r--r--testing/fheroes2/APKBUILD27
1 files changed, 9 insertions, 18 deletions
diff --git a/testing/fheroes2/APKBUILD b/testing/fheroes2/APKBUILD
index 6323e2f6922..c49ee8c0963 100644
--- a/testing/fheroes2/APKBUILD
+++ b/testing/fheroes2/APKBUILD
@@ -1,15 +1,17 @@
# Contributor: Grigory Kirillov <txgk@bk.ru>
-# Maintainer: Grigory Kirillov <txgk@bk.ru>
+# Maintainer: ovf <ovf@mm.st>
pkgname=fheroes2
-pkgver=0.9.16
+pkgver=1.0.13
pkgrel=0
-pkgdesc="Recreation of HoMM2 game engine"
+pkgdesc="Recreation of Heroes of Might and Magic II game engine"
url="https://github.com/ihhub/fheroes2"
arch="all"
license="GPL-2.0-only"
options="!check" # no test suite
makedepends="
gettext
+ gnu-libiconv
+ sed
sdl2-dev
sdl2_image-dev
sdl2_mixer-dev
@@ -20,22 +22,11 @@ source="https://github.com/ihhub/fheroes2/archive/$pkgver/fheroes2-$pkgver.tar.g
install="$pkgname.post-install"
langdir="/usr/share/$pkgname/files/lang"
-[ "$CARCH" = "riscv64" ] && options="$options textrels"
-
build() {
make FHEROES2_WITH_IMAGE=1 FHEROES2_DATA=/usr/share/fheroes2
-
- # hu lt nl tr:
- # these languages require iconv TRANSLIT extension to be built (musl doesn't support that)
- # ro:
- # just fails to build because "ISO-8859-16" charset is not portable
- # fr:
- # fails with "make: *** [Makefile:33: fr.mo] Error 254"
- for lang in hu lt nl tr ro fr; do
- rm files/lang/$lang.po
- done
-
- make -C files/lang
+ # Use GNU iconv instead of musl-based one, because this project uses
+ # TRANSLIT iconv extension which is not present in musl implementation.
+ make -C files/lang ICONV=gnu-iconv
}
package() {
@@ -51,5 +42,5 @@ package() {
}
sha512sums="
-6b954cd1d0d151c209fe5e94793e3f9bfdd5fd7a5eeb207e79475eb7c76f13934483ccce89a9f6790bb07c87d3456970feef4d3bbca7ab94261361ffa8a77ee1 fheroes2-0.9.16.tar.gz
+989b71ad6f217c5283441392e5a4bdee8b49d07261dba05372e185dbee239f4bb7b75290ca0b86fbf3dbf98edfaaca6234adc7e0483495ea799bf1636af3f6bc fheroes2-1.0.13.tar.gz
"