aboutsummaryrefslogtreecommitdiffstats
path: root/testing/filite/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/filite/APKBUILD')
-rw-r--r--testing/filite/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/filite/APKBUILD b/testing/filite/APKBUILD
new file mode 100644
index 00000000000..6f1a924b3c7
--- /dev/null
+++ b/testing/filite/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: guddaff <guddaff@protonmail.com>
+# Maintainer: guddaff <guddaff@protonmail.com>
+pkgname=filite
+pkgver=0.3.0
+pkgrel=2
+pkgdesc="simple and light pastebin"
+url="https://github.com/raftario/filite"
+arch="x86_64 armv7 armhf aarch64 x86" # limited by rust/cargo
+license="MIT"
+makedepends="cargo sqlite-dev cargo-auditable"
+source="$pkgname-$pkgver.tar.gz::https://github.com/raftario/filite/archive/refs/tags/v$pkgver.tar.gz
+ fix-build.patch
+ system-sqlite.patch
+ "
+
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
+
+build() {
+ cargo auditable build --release --frozen
+}
+
+check() {
+ cargo test --frozen
+}
+
+package() {
+ install -Dm755 target/release/filite -t "$pkgdir"/usr/bin/
+}
+
+sha512sums="
+9d55a28e3578a8ef010ef184b517de3b59753a1058d82970ad8ff178d219e182eeaa4d31f38330735bddb89dbfbf297229026a69191c8a90c94f2e1dfda06106 filite-0.3.0.tar.gz
+994cd9439016cb5c20f06e5b7a16d9b17edfcf43872e2277b3ec87654f4350dd1e0d45c19f6dfad0b85a6e74090ce6327520fe2a0168e29ac2d3d7868b87365d fix-build.patch
+dfdfb3c75383876bb16e60ba5b035e76adf3851c30603648b643ebc5c6be2b98097ff39c1e5f2c808662fb49000513997a96bd4b14899a704c19ba330d092a6b system-sqlite.patch
+"