aboutsummaryrefslogtreecommitdiffstats
path: root/testing/flightgear
diff options
context:
space:
mode:
Diffstat (limited to 'testing/flightgear')
-rw-r--r--testing/flightgear/APKBUILD6
-rwxr-xr-xtesting/flightgear/flightgear.post-install10
2 files changed, 13 insertions, 3 deletions
diff --git a/testing/flightgear/APKBUILD b/testing/flightgear/APKBUILD
index 7492ae6c949..b71be83fd67 100644
--- a/testing/flightgear/APKBUILD
+++ b/testing/flightgear/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=flightgear
pkgver=2018.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Sophisticated flight simulator"
url="http://flightgear.org"
arch="all !aarch64"
@@ -11,8 +11,8 @@ makedepends="$depends_dev boost-dev cmake curl-dev dbus-dev eudev-dev
freeglut-dev glew-dev libx11-dev libxi-dev libxmu-dev mesa-dev
openal-soft-dev openscenegraph-dev plib qt5-qtbase-dev
qt5-qtdeclarative-dev simgear zlib-dev"
-install=
-subpackages="$pkgname-doc"
+install="$pkgname.post-install"
+subpackages="$pkgname-doc $pkgname-dbg"
source="http://downloads.sourceforge.net/project/$pkgname/release-${pkgver%.[1-9]*}/$pkgname-$pkgver.tar.bz2
musl-fixes.patch
"
diff --git a/testing/flightgear/flightgear.post-install b/testing/flightgear/flightgear.post-install
new file mode 100755
index 00000000000..595cb797bed
--- /dev/null
+++ b/testing/flightgear/flightgear.post-install
@@ -0,0 +1,10 @@
+#!/bin/sh
+echo
+echo " Please download the flightgear-data-VERSION.tar.bz2 file at:"
+echo
+echo " http://downloads.sourceforge.net/project/flightgear"
+echo
+echo " and extract it in /var/lib/flightgear"
+echo " before running the program or change its location"
+echo " by setting the variable FG_ROOT"
+echo