aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fluent-bit
diff options
context:
space:
mode:
Diffstat (limited to 'testing/fluent-bit')
-rw-r--r--testing/fluent-bit/10-def-core-stack-size.patch13
-rw-r--r--testing/fluent-bit/APKBUILD8
-rw-r--r--testing/fluent-bit/chunkio-static-lib-fts.patch16
3 files changed, 26 insertions, 11 deletions
diff --git a/testing/fluent-bit/10-def-core-stack-size.patch b/testing/fluent-bit/10-def-core-stack-size.patch
new file mode 100644
index 00000000000..29bda6feb6e
--- /dev/null
+++ b/testing/fluent-bit/10-def-core-stack-size.patch
@@ -0,0 +1,13 @@
+--- a/include/fluent-bit/flb_coro.h
++++ b/include/fluent-bit/flb_coro.h
+@@ -62,9 +62,7 @@
+ void *data;
+ };
+
+-#ifdef FLB_CORO_STACK_SIZE
+-#define FLB_CORO_STACK_SIZE FLB_CORO_STACK_SIZE
+-#else
++#ifndef FLB_CORO_STACK_SIZE
+ #define FLB_CORO_STACK_SIZE ((3 * PTHREAD_STACK_MIN) / 2)
+ #endif
+
diff --git a/testing/fluent-bit/APKBUILD b/testing/fluent-bit/APKBUILD
index aaf0c89919d..5970ba70861 100644
--- a/testing/fluent-bit/APKBUILD
+++ b/testing/fluent-bit/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: wener <wenermail@gmail.com>
# Maintainer: wener <wenermail@gmail.com>
pkgname=fluent-bit
-pkgver=1.6.10
+pkgver=1.7.0
pkgrel=0
pkgdesc="Fast and Lightweight Log processor and forwarder"
url="https://fluentbit.io/"
@@ -23,6 +23,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/fluent/fluent-bit/archive/v$
fluent-bit.confd
fluent-bit.initd
chunkio-static-lib-fts.patch
+ 10-def-core-stack-size.patch
"
# enable check when this solved - https://github.com/fluent/fluent-bit/issues/2464#issuecomment-673280055
options="!check"
@@ -61,7 +62,8 @@ package() {
mv "$pkgdir"/usr/etc/* "$pkgdir"/etc
}
-sha512sums="bddce2a4b041a5671cc3e1e6c749843fd0be28294442922994822ae9c5686b2ecdeaa6615d1745a289786304c083d15c64d6bae31f661da1f77df8e610a5e31c fluent-bit-1.6.10.tar.gz
+sha512sums="bcfa921fc6bb504da1a2f8382ab7c607a48424a6f1cfccc17a451ee9da09430c146f1e31f85c35eeaa5f08e20d56149c8375ce06b75f1d3a73ba51833465b6ea fluent-bit-1.7.0.tar.gz
f6431397c80a036980b5377b51e38aec25dfceeb8dbe4cd54dce1f6e77d669d9f8daf983fcc96d25332385888f1809ced5e8ab0e8ccfcd93d19494036e3dc949 fluent-bit.confd
8ba6c8e84dee90176f9b4375fb2c6444fa5d32fa601d9bcf3ea7960fec87f1ef664f175caf08bd0b052843e971efdbf08e2a5cd180ad9a8f23ff2c5cb233814f fluent-bit.initd
-5ec7fb96850a5b038eb27fc0c0e1823e7976c467c05e846da668f32ad7a124d86d700386a684b335726ad1958b2422b0b0dc0aa36172f94ac4747339d91686bd chunkio-static-lib-fts.patch"
+6bd7d8b4da93a17f29b6ea1e0286ea226d0e376024284741110936779b3229bd8d6cd03ffbdc5d3b4842294e7f32a888de0dd16b0851b65d91b062ca58530ea0 chunkio-static-lib-fts.patch
+cecfa26e240491ed059f27e209eec8408514f0a59c2b5287fe837daba01179c15c33e8bc88e3bbe95ff39810f7fef6ef806643efbd84fb6dd86a3a7e188a319d 10-def-core-stack-size.patch"
diff --git a/testing/fluent-bit/chunkio-static-lib-fts.patch b/testing/fluent-bit/chunkio-static-lib-fts.patch
index 97f144e589f..c3700a4a0a7 100644
--- a/testing/fluent-bit/chunkio-static-lib-fts.patch
+++ b/testing/fluent-bit/chunkio-static-lib-fts.patch
@@ -1,10 +1,10 @@
--- a/lib/chunkio/src/CMakeLists.txt
+++ b/lib/chunkio/src/CMakeLists.txt
-@@ -26,6 +26,7 @@
- if(CIO_LIB_STATIC)
- add_library(chunkio-static STATIC ${src})
- target_link_libraries(chunkio-static cio-crc32)
-+ target_link_libraries(chunkio-static fts)
- if(CIO_SANITIZE_ADDRESS)
- add_sanitizers(chunkio-static)
- endif()
+@@ -12,6 +12,7 @@
+ )
+
+ set(libs cio-crc32)
++set(libs ${libs} fts)
+
+ if(${CMAKE_SYSTEM_NAME} MATCHES "Windows")
+ set(src