aboutsummaryrefslogtreecommitdiffstats
path: root/testing/getting-things-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'testing/getting-things-gnome')
-rw-r--r--testing/getting-things-gnome/APKBUILD21
-rw-r--r--testing/getting-things-gnome/remove-unused-keyword.patch19
2 files changed, 9 insertions, 31 deletions
diff --git a/testing/getting-things-gnome/APKBUILD b/testing/getting-things-gnome/APKBUILD
index f4b703df46a..7e829e21642 100644
--- a/testing/getting-things-gnome/APKBUILD
+++ b/testing/getting-things-gnome/APKBUILD
@@ -1,24 +1,22 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=getting-things-gnome
-pkgver=0.5
-pkgrel=0
+pkgver=0.6
+pkgrel=3
pkgdesc="A personal tasks and TODO-list items organizier for GNOME, inspired by the Getting Things Done methodology"
url="https://wiki.gnome.org/Apps/GTG"
arch="noarch"
license="GPL-3.0-or-later"
-depends="python3 py3-xdg py3-dbus py3-gobject3 py3-liblarch py3-lxml"
-makedepends="py3-setuptools gettext meson"
-checkdepends="py3-nose py3-pyflakes py3-mock py3-pycodestyle xvfb-run"
+depends="python3 py3-cairo py3-xdg py3-dbus py3-gobject3 py3-liblarch py3-lxml"
+makedepends="py3-setuptools py3-pytest gettext gtksourceview4 itstool meson"
+checkdepends="py3-nose py3-pyflakes py3-mock py3-pycodestyle py3-caldav py3-vobject xvfb-run"
subpackages="$pkgname-doc $pkgname-lang"
-source="$pkgname-$pkgver.tar.gz::https://github.com/getting-things-gnome/gtg/archive/v$pkgver.tar.gz
- remove-unused-keyword.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/getting-things-gnome/gtg/archive/v$pkgver.tar.gz"
builddir="$srcdir/gtg-$pkgver"
build() {
abuild-meson output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
@@ -30,6 +28,5 @@ package() {
}
sha512sums="
-631f5343301d7d72211398152fa081c0fa15154babc7ec900f13a39a2677d0edaf4fea534a83284207e8019926c9108dc1d8f25bdbeae85ef0665dfe1c7b768a getting-things-gnome-0.5.tar.gz
-21abbb30321e8c178dd0d4118196145c72145150915adfad9b220d149cb52828c3ba1714aeaae79e5b69560ad0d37c31358935e2ec7da8d1a8e65fdc533a821d remove-unused-keyword.patch
+68a5229c17b85b87a9a134a08e5e86fbf24d28d6ce55e848c17eef650620d6f56172ee495cb113f4279b34c19127ae03981e2feec5a39dc51be49e387e458600 getting-things-gnome-0.6.tar.gz
"
diff --git a/testing/getting-things-gnome/remove-unused-keyword.patch b/testing/getting-things-gnome/remove-unused-keyword.patch
deleted file mode 100644
index de290a22ba6..00000000000
--- a/testing/getting-things-gnome/remove-unused-keyword.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-This is not applicable upstream as this breaks rebuilding translations whenever it changes, and we don't want that since we just building it once for packaging, not actively developing on it.
-
-So keep this here until https://github.com/getting-things-gnome/gtg/issues/720 is solved
-
-diff --git a/GTG/plugins/meson.build b/GTG/plugins/meson.build
-index 7ecb530..f6b2744 100644
---- a/GTG/plugins/meson.build
-+++ b/GTG/plugins/meson.build
-@@ -23,9 +23,7 @@ foreach plugin : gtg_plugins
- install_dir: plugin_install_dir,
- type: 'desktop',
- args: ['--keyword=name', '--keyword=short-description', '--keyword=description'],
-- build_by_default: true,
-- build_always_stale: true
-- # build always because otherwise new translations won't be applied
-+ build_by_default: true
- )
- subdir(plugin.underscorify())
- endforeach