aboutsummaryrefslogtreecommitdiffstats
path: root/testing/git-bug/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/git-bug/Makefile.patch')
-rw-r--r--testing/git-bug/Makefile.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/testing/git-bug/Makefile.patch b/testing/git-bug/Makefile.patch
new file mode 100644
index 00000000000..131d1db3973
--- /dev/null
+++ b/testing/git-bug/Makefile.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,8 @@
+ all: build
+
+-GIT_COMMIT:=$(shell git rev-list -1 HEAD)
+-GIT_LAST_TAG:=$(shell git describe --abbrev=0 --tags)
+-GIT_EXACT_TAG:=$(shell git name-rev --name-only --tags HEAD)
++GIT_COMMIT?=$(shell git rev-list -1 HEAD)
++GIT_LAST_TAG?=$(shell git describe --abbrev=0 --tags)
++GIT_EXACT_TAG?=$(shell git name-rev --name-only --tags HEAD)
+ UNAME_S := $(shell uname -s)
+ XARGS:=xargs -r
+ ifeq ($(UNAME_S),Darwin)