aboutsummaryrefslogtreecommitdiffstats
path: root/testing/git-cola/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/git-cola/APKBUILD')
-rw-r--r--testing/git-cola/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/testing/git-cola/APKBUILD b/testing/git-cola/APKBUILD
index 91c6399f818..818a9245240 100644
--- a/testing/git-cola/APKBUILD
+++ b/testing/git-cola/APKBUILD
@@ -1,31 +1,36 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
# Maintainer:
pkgname=git-cola
-pkgver=3.10.1
-pkgrel=0
-pkgdesc="GUI application for git built on Python & Qt5"
+pkgver=4.4.1
+pkgrel=1
+pkgdesc="GUI application for git built on Python & Qt"
url="https://git-cola.github.io"
-arch="noarch !armhf" # qtdeclarative
+arch="noarch !armhf !riscv64" # py3-qt6
license="GPL-2.0-or-later"
-depends="python3 py3-qt5"
-checkdepends="py3-nose"
-makedepends="py3-setuptools"
-subpackages="$pkgname-doc"
+depends="python3 py3-qt6 py3-qtpy"
+makedepends="py3-setuptools py3-setuptools_scm py3-gpep517 py3-installer py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-doc $pkgname-pyc"
source="git-cola-$pkgver.tar.gz::https://github.com/git-cola/git-cola/archive/v$pkgver.tar.gz"
# testsuite hangs after a while.
options="!check"
build() {
- make PYTHON=python3
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 1
}
+
check() {
- make PYTHON=python3 test
+ pytest
}
package() {
- make PYTHON=python3 prefix=/usr DESTDIR="$pkgdir" install
+ python3 -m installer -d "$pkgdir" \
+ .dist/git_cola*.whl
}
sha512sums="
-79496023bfaa05049079eec2cdaf8449a6598faebedb4a13acf178209edc63e725eb1b003700a1dcfee09072d34e5a49d7053f070e45b498562cc124cd0582d4 git-cola-3.10.1.tar.gz
+3e4e1cb8cd148b34e663c72c6b3d1e887815b5a86558ffbf13a19a5dfd3fb6b37c123290dc514b6f098893587dc67ca34424aaad5482768795e353f0efe92797 git-cola-4.4.1.tar.gz
"