aboutsummaryrefslogtreecommitdiffstats
path: root/testing/git-secret/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/git-secret/makefile.patch')
-rw-r--r--testing/git-secret/makefile.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/testing/git-secret/makefile.patch b/testing/git-secret/makefile.patch
new file mode 100644
index 00000000000..a864c95841a
--- /dev/null
+++ b/testing/git-secret/makefile.patch
@@ -0,0 +1,15 @@
+--- a/Makefile
++++ b/Makefile
+@@ -39,10 +39,10 @@
+ git clone https://github.com/sstephenson/bats.git vendor/bats; fi
+
+ .PHONY: test
+-test: install-test clean build
++test: build
+ @chmod +x "./utils/tests.sh"; sync; \
+ export SECRET_PROJECT_ROOT="${PWD}"; \
+- export PATH="${PWD}/vendor/bats/bin:${PWD}:${PATH}"; \
++ export PATH="${PWD}:${PATH}"; \
+ "./utils/tests.sh"
+
+ #